Problem Connecting to UI


I put a fresh install on a SD card with the newest Buster-Lite last night. Everything was going swimmingly until this morning, where I can no longer connect to the ui in my web browser. I can Putty into the Pi, and restarting the services or rebooting the pi does not fix the issue. Any ideas?

What error is shown when you try to connect?

Could you please run brewblox-ctl log?

Ok, so I ran a brewblox-ctl update command and now I can reconnect, which is strange because it was already up to date. However, I was having the same issue on stretch-lite which I had the same problem which led me to nuke the card and start over. Here is the brewblox-ctl log link that I ran when I was trying to fix my stretch based install…

Your log is showing multiple seemingly unrelated errors in system services. They may have been caused by a deteriorating SD card, but that’s more of a hunch than a conclusion.

How old is your card, and how long has it been running BrewBlox? If it has been running for half a year or more, you may want to consider using a tool like Win32 Disk Imager to clone your SD card.

Hmm, that is interesting, it had probably been running for about half a year or so. I will look into a new card. Thanks!

Hey Bob, I’m kind of having the same problem. I updated to the Dec 17th release which had a spark firmware update. I started my session on new years eve. Everything works find but after some time the server losses connection to the spark. The UI says the services are running but won’t get past that. I ssh into the pi and I can ping the spark just fine. I restart services and the pi but the only thing that will get things working again is power cycling the spark. At which point things will well again for a bit and then lose connection again.

Here is my log:

What log specifically should I be looking at for connection issues like this?

You’re posting the correct log already.

It looks like it’s completely dropping connection. Is it possible to connect the Spark over USB to check if problems also occur there?

When you reboot the Spark, is it still showing its IP address?

Some possible causes in the environment are:

  • the router is hopping wifi channels
  • the spark is losing wifi signal for extended periods

On our end, we’re working on improving error/crash reports from the controller, to better pin down the remaining issues that all manifest as “lost connection”.

So my AP does reset every night at 12:30. And looking at the graph, it looks like that’s when the connection drops. But the rest of my wifi devices reconnect just fine. And yes, my spark keeps it’s ip address on the display. And even though the UI says it can’t connect to the spark I can ping it from the pi.

I tried some different sd cards and I was still having problems. Upon disconnecting the USB cable for the spark, and rebooting, I was able to get access back, but it could not find the spark over wifi. The spark was connected to my network based upon my router. If I plugged in the USB to the pi from the spark, the web UI would die again. I tried to add a new service, and discover services with a specified ip and it still would not find any devices. Since I was able to putty in while USB was connected, I did a re flash of the spark and the wifi config. Now everything seems to be working for now. It has been stable for a while now. Not sure wtf was going on.

If I understand correctly, it’s now using Wifi?

When switching wifi -> usb, you do need to restart the spark service. It can only see usb devices plugged in when it was started.

For figuring out connections, brewblox-ctl discover is a useful tool.

How are you powering the pi?
For a spark 3, you can see the actual 5V measures voltage on the Spark Pins widget when expanded to full settings. What does it say?

If you plug nothing into the spark, does it still happen?

It sounds like the pi might be underpowered or the Spark is drawing too much current.

It sounds like your pi is underpowered or

Currently, the spark is now on wifi only, no USB to the pi. Pi is being powered by a 1 amp USB wall brick. Spark is powered by its own power jack via different wall brick.

Before when the problem started everything as as above, but I had the spark connected to the pi via USB.

To overview a bit. I had updated to the newest release plus firmware and had no issue. Then suddenly I could not connect to the ui, the page would never load, just a white screen. I was able to putty to the pi. Both devices showed up on my router wifi. I tried restarting the pi and the spark by unplugging both from power then powering back on at the same time. No progress. Thinking it might be a problem with rasbian stretch, I flashed the card to newest buster lite release and fresh installed brewblox. This did not fix the issue until I ran an update command and then it worked again for a couple hours. It reverted back to not working so I tried a different sd card with a fresh install, which did not work. From here, I disconnected the pi from the spark and rebooted the pi. I was able to get to the web ui, but did not have the spark connected. I plugged the spark back into the pi and I could no longer reach the web ui. This is when I was trying to use the discover command and could not find anything. So I plugged spark back into the pi and re flashed it and reran wifi command. From here, I was not sure it was working so I unplugged the spark again from the pi. And I think that is around the time when the web ui loaded again.

I cannot recall all of the details, but I do remember that I ran the editor command in putty and that was the same time that the web ui loaded back, not sure if that was just a coincidence of timing or it triggered something.

Edit: there seems to be someone else who posted a different issue in this thread, not sure what is relevant.

1A is not enough for the pi!

Most phone chargers are not suitable in general. You need a proper power supply of at least 2A. I think 2.5A even is recommended for the pi 3.

Interesting, I will try to upgrade the power supply. I thought it was only like an amp max it drew at full load without other things connected.

It will probably consume much less in most conditions, but you are connecting other things.
It is not worth the risk of data corruption and troubleshooting time.

If the spark is connected via USB to the pi and it has its owned supplied power jack, is it still pulling it’s full load from the USB?

Edit: I ask because the configuration I have been using has run flawlessly up until this point. It has been rock solid for months. I suppose I could have been on the cusp of needed power and just physically deteriorated. I will try plugging the USB back in tonight and rebooting both devices. Then regardless the outcome I will upgrade the power supply to 3A and try again.

No, if it has 12V it will draw power from that 12V supply.

But 1A for the pi 3 is underpowered, regardless of the Spark. They sell them with 2.5A supplies for a reason.
Official docs here:

I won’t help to debug a pi powered with a 1A supply, sorry. It is too cheap to rule out this possible cause of reliability to spend time trying to get it stable without changing the supply.

I understand. As I stated above. I will do some testing then switch to 3A supply no matter what, that way I can be sure it was the power supply. I’ll report back here with anything useful that I find.

1 Like

For the sake of closing out this thread. I plugged the spark back into the pi and rebooted the spark. All is working still. I will be changing the pi power supply to a 5V 3A supply I have. I will continue to monitor and report back if there is any future problems.

1 Like