Problem finding spark after raspiBackup

Hi. I installed a program called raspiBackup on the rpi that automatically backups the whole SD card to another folder on the network once every week. The brewblox service is shut down before backup and started when the backup is finished. But after the backup is finished, brewblox can’t seems to find the spark. If I reboot the rpi then everything is working again.

Here is log before backup:

Log after backup:

Not sure if there’s anything to do about it, right now I’ve set up the rpi to reboot an hour after backup.

I see two issues in your logs: hangups, and a failed wifi discovery.

We already solved multiple bugs that can cause hangups, but there appear to be more.
Restarting the Spark may solve the problem for about a week.

If this works, you can also automate it by sending a POST request to /spark-one/system/reboot/controller. For more info about Spark endpoints, see /spark-one/api/doc.

Wifi discovery is done using mDNS. I’m not familiar with raspiBackup, and don’t know how and where it may disrupt network interfaces and mDNS propagation. You could check the status of the avahi-daemon service just after backups.

Alternatively, you could restart the docker services just after backup, and check whether that’s sufficient.

Ok thanks Bob, I will test some more tomorrow

It was the avahi-daemon service that wasn’t started after backup is finished. Added the service to the list of services to be started. Now it works. Thanks for pointing me in the right direction :slight_smile:

1 Like