Raspberrypi to Arduino

Hi I have installed /brewpi and /brewpi-tools on my Raspberrypi v3 but would like to control the brew via Arduino boards is this possible.

Yes! I Have it running and I’m getting ready to start my first brew.

You’ll need to download firmware version 0.2.10 (brewpi-arduino-uno-revC-0_2_10.hex) from the github repo and use a separate program to load it to the arduino.

Here are my notes on getting the Pi loaded and configured (assumes a little pi/linux experience.) . Basically, once you get Raspbian running you need to add a few things to make BrewPi happy.

	flash raspbian-stretch-lite image to microSD
    re-mount the SD in the computer
	cp wpa_supplicant.conf /Volumes/boot
		ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
			psk="WiFi Password"
	touch /Volumes/boot/ssh
boot the raspberrypi
	expand file system
add repo to apt-get (at the end of /etc/apt/sources.list):
	deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
update packages:
	sudo apt-get update
	sudo apt-get upgrade
install php5:
	sudo apt-get -y install php5 php5-curl php5-cli php5-mysql php5-gd git arduino-core
	sudo update-alternatives --set php /usr/bin/php5
install brewpi:
	git clone https://github.com/BrewPi/brewpi-tools.git ~/brewpi-tools
	sudo ~/brewpi-tools/install.sh
change to legacy brewpi for arduino:
	sudo su - brewpi
		git checkout legacy
		cd /var/www/html
		git checkout legacy
	sudo reboot

The details for all the steps are available on the web or this forum. Have fun!

Edit: Sorry, I forgot to mention that I am using a Mac.

Here’s a pic of my recently completed BrewPi controller:

That looks good what size is the box

12" H x 10" W x 4.5" D

Thanks bvehorn,

your instructions are very consise and it worked, cheers

Glad that my notes were helpful. I just bought my freezer last week and am testing the system with water right now. Looks good so far. Unfortunately, there wasn’t space in the area where I placed the freezer for the spiffy box I built, so the components are mounted to the wall just above the height of the opened freezer door.

Thanks for the post. I had a legacy brewpi (Arduino) that was working fine until the memory chip failed. I installed a new memory chip and reinstalled raspbian-jessie and brewpi using your post as guidance. The brewpi web page came up and I tried to reset my devices (sensors and relays). However, when I tried to refresh my devices, I received the following:
Error while receiving device configuration: SyntaxError: Unexpected token C in JSON at position 0

Any clue?

Never mind. I solved the issue by running
sudo ~/brewpi-tools/updater.py --ask
and choosing the legacy options.

1 Like