Release candidate 0.5.0 (WiFi support!)


Your information has been very helpful. bugs fixed based on your info:

  • WiFi disconnect handling
  • State display
  • Documentation


Hi Elco,

Updated to 0.5.0 rc2, just a query regarding the wifi connection between the brewpi and the rpi3. I have relocated the rpi3 a couple of times and have found that I cannot get a connection between the two i.e.script running, despite both being connected to the wifi, unless I reboot the brewpi after the rpi3 has booted.
Apart from that all is good, great work!



That’s strange, would think that the boot order is of no influence, unless it affects the IP addresses that are handed out. Are you sure you have set up your static IP address correctly?


I have set the statics on the router, they connect as they should but unless I reboot the brewpi they don’t communicate.


Okay, let’s try to debug.

Before rebooting the spark, does it respond to ping?
What is the color of the LED on the BrewPi?
What affect does starting and stopping the script have?
What is the version number reported when you boot the BrewPi?


Ok, I am only an enthusiastic ametur here. My RPi3 is now located in the house next to the wifi router, the Brewpi is in the garage. Prior to this “test” all working ok.
I have just rebooted the Pi which has reconnected to the network. There is now no script running. The brewpi is still connected to the network slow green pulsing led. Ping to the Brewpi.

Last login: Thu Jun 29 22:30:47 on ttys000
Daves-MacBook-Pro:~ dave$ ping
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=255 time=5.371 ms
64 bytes from icmp_seq=1 ttl=255 time=6.002 ms
64 bytes from icmp_seq=2 ttl=255 time=10.080 ms
64 bytes from icmp_seq=3 ttl=255 time=4.109 ms
64 bytes from icmp_seq=4 ttl=255 time=5.424 ms
64 bytes from icmp_seq=5 ttl=255 time=3.447 ms
64 bytes from icmp_seq=6 ttl=255 time=3.152 ms
64 bytes from icmp_seq=7 ttl=255 time=3.812 ms
64 bytes from icmp_seq=8 ttl=255 time=3.728 ms
64 bytes from icmp_seq=9 ttl=255 time=5.003 ms
— ping statistics —
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 3.152/5.013/10.080/1.918 ms

Script…no effect when hitting the “button”

When I reboot the Brewpi I get initially touch screen to recalibrate then it displays the new screen.
And now the script is running.


When you hit the start script button, it removes a file that prevents cron from restarting the script. The web interface does not have access to start a python script, so it only removes a file to notify that the script should run again.

This can take up to a minute.

You should not have to calibrate the touch screen each time. Can you try clicking the ‘rest factory defaults’ button at the bottom of the advanced settings? That should re-initialize the eeprom. See if it still asks for touch calibration each time afterwards.


Just did a reboot if my WiFi AP, all three setups came back online and seem to run fine without me having to do anything.


That is excellent news @chixxi.

Guess the fix worked :slight_smile:


I don’t have to calibrate the screen, it just briefly appears before booting.


oh you mean the ‘tap now to recalibrate’, which always shows? It doesn’t actually enter the calibration routine where you have to press the 2 crosses?


Yes, sorry wasn’t explicit enough.


Low pri bug: the message at the very end of the new Python script has a few typos. It says “Please refresh your browser with ctrl-F5 to make sure it is not swowing and old cached version.” (should be ‘showing an’).

I would make a pull request but that would require I learn how to update Python code in your repo, and unfortunately I am a lazy man.


haha, thanks for your input. PR not necessary and fixed.


Hi Elco,

Just tried to update to 0.5.0 RC-2 but I’m getting some strange issues the log shows this:

Jun 30 2017 21:39:18 Warning: minimum BrewPi version compatible with this script is 0.5.0 but version number received is 0.4.4

I tried to re-update and get the following message:

Jun 30 2017 21:38:42 Opening serial port
Checking current version: Found BrewPi v0.4.4 build 0.4.4-0-g6d17ff1, running on a Particle Core with a V1 shield on port /dev/ttyACM0

Requesting old settings from Spark Core…
Saved old settings to file settings-Jun-30-2017-21-38-46.json

Problem flashing file: 68
Please try again.
BrewPi script will restart automatically.
Firmware update done

*** Done updating BrewPi! ***

The website has changed to show the temps in the middle at the top but it only shows the fridge temp reading:and not the others.

Any ideas?


Yes, it is trying to update via serial, which doesn’t work well currently.

For the photon it defaults to DFU when running as root, for the core I think it doesn’t. Please try running separately, with --dfu to force dfu mode.


I’m not getting the option to update to 0.5.0 with command only 0.4.4 and older. Do i have to point somewhere else, if so how?


Ah, ok I have to use --beta as well.


I just need to check I’m doing this right. The commands I use:

cd /home/brewpi/utils
sudo python -dfu -beta

I then get the following and then it just waits and nothing further happens:

Trying to automatically reboot into DFU mode and update your firmware.

If the Photon does not reboot into DFU mode automatically, please put it in DFU mode manually.
Running command: sudo /usr/bin/python /home/brewpi/utils/ --autodfu --noreset --file=/home/brewpi/utils/downloads/0.5.0-rc.2/brewpi-core-0.5.0-rc.2.bin
Will automatically reboot newly detected photons into DFU mode
Using local files instead of downloading a release.

Using binary file: /home/brewpi/utils/downloads/0.5.0-rc.2/brewpi-core-0.5.0-rc.2.bin
dfu-util not found, downloading dfu-util…
Detecting DFU devices
Did not find any DFU devices.
Is your Photon or Spark Core running in DFU mode (blinking yellow)?
Waiting until a DFU device is connected…
Found new serial port connected: (’/dev/ttyACM0’, ‘Particle Core’)
Putting Particle Core in DFU mode


Hi Elco,

Decided to swap out the Spark for a Photon which went well (apart from discovering the reset and mode holes don’t line up with the buttons after I had put it all back together, doh!)

The update is up and running and seems to be working fine. The only thing that I have noticed so far is that the lag time between the refresh on the website header and the actually temps showing on the Brewpi is quite long so they never match. Is this something that can be changed somewhere?

Also can I now use beer constant mode for controlling the HLT and Herms or do I still need to stick with fridge constant?