Revert BrewBlox back to BrewPi

I recently tried using BrewBlox but am having a ton of problems. is it possible to flash the SparkV3 to the previous 0.5.10 firmware so I can go back to running BrewPi?

I’m sorry to hear that. Was this due to bugs / nonfunctional software, or complexity of use?

You should be able to re-flash the brewpi firmware by following the original install instructions.

I had problems with dashboards emptying. I would go through the wizard, create the brewpi classic dashboard. But if I navigated away then back to the dashboard, it was blank. I tried removing the dockers and remove ~/brewblox a few times, but each time resulted in the same problem. The final time I was unable to enable any of the widgets. This was done on a new microsd card, formatted and installed according to the Getting Started guide.

I was brewing and ESB at the time so needed to switch back to a reliable setup.


Dashboards going blank sounds like it has trouble connecting to the datastore, but for any analysis beyond that I’d need logs or error messages.

I’ll put up an issue for it, to keep track of the problem.

For flashing BrewPi firmware back:

docker run -it --name brewpi-dfu --privileged -v ~/brewpi-data:/data --rm brewpi/brewpi-ubuntu python utils/ --trigger
docker run -it --name brewpi-dfu --privileged -v ~/brewpi-data:/data --rm brewpi/brewpi-ubuntu python utils/ --noreset --autodfu

However, BrewPi has seen its last release and BrewBlox will be the way forward. So we would rather help you resolve the issues.

In a couple of weeks, when i have more time I’ll try installing BrewBlox again, and let you know if the problems repeat. I’ll also try to save any logs from the previous attempt.

I haven’t been brewing any over the winter do building a new brew stand, trying to catch up now that the weather is nice.

Thanks for the help so far from both of you.

I finally got around to upgrading the BrewPi to BrewBlox. I replaced both the SD card and RPi, My guess is the RPI was going bad, I was having a few issues with it running both BrewBlox and BrewPi, even though I tried new SD cards.

One minor problem with BrewBlox is using Microsoft Edge, I see “Block Ferment Fridge Sensor not found on service spark-one” for all the widgets, even though Firefox and Chrome display normally. I usually don’t use Edge but I do have a shortcut on the start menu for the BrewBlox.

Officially, we don’t support Edge. I will have a look though: if it’s something simple we may as well fix it. The rest of the system is working Ok on Chrome/FF?

Yes it is working great.