RPI Updated communication to BrewPi lost [Fixed]

Thought I’d update my RPI before updating to 0.4.2 however following the reboot I can no longer connect to the BrewPi. I’m getting the following in the logs:

Dec 30 2015 17:47:05 Opening serial port
Traceback (most recent call last):
File “/home/brewpi/brewpi.py”, line 330, in
ser = util.setupSerial(config, time_out=0)
File “/home/brewpi/BrewPiUtil.py”, line 132, in setupSerial
ser = serial.Serial(port, baudrate=baud_rate, timeout=time_out, writeTimeout=0)
TypeError: init() got an unexpected keyword argument ‘writeTimeout’

I’m assuming the update changed something in the com port config but I can’t seem to find out what.

Anyone got any ideas?

I think pyserial was just updated to 3.0. This breaks compatibility. I’ll look for a workaround. In the meantime, downgrading to 2.7 will probably help.

@Elco Thanks for the quick response, I was able to update my brewPi to 0.4.2 using the DFU method but it’s still not connecting normally so I think you are right.

Struggling to workout how to downgrade to Pyserial 2.7, is there an easy way?

I have released the fix. Just update the script.

1 Like

@Elco Worked a treat, thanks.