Script keeps stopping


#1

I have a brew going right now and so far the script has stopped running twice in two days. When I load up the page to see how it is doing the box on the upper right is red with “Script Not Running!” in it. I am unable to restart the script using the button. I am using Chrome to monitor.


#2

How have you installed BrewPi?
The recommended way is to use docker now, as described on the wiki.

The latest version of the script also does not exit if the connection to the Spark has been lost, but tries to restore it instead.

Not being able to start the script could be a permissions issue, but if you are running with docker, this will not be the case.

Try upgrading to the latest version and see if the problem persists.


#3

I installed it with docker about a year ago. It’s been running perfect since then. I haven’t done any updates since the initial install.

I tried to update via both methods in the wiki.

  1. SSH to Raspberry Pi and do a pull. Everything seems to download fine but I get an error when its extracting. It looks like it completes a file that is 160.5MB, then during the next file it throws an error and it stops. The file says “Extracting 3.552MB/3.552MB”. The error is:

failed to register layer: Error processing tar file(exit status 1): unexpected EOF

  1. Trying to update from within the container I get:

rpc error: code = 2 desc = oci runtime error: exec failed: container_linux.go:247: starting container process caused “exec: “cd”: executable file not found in $PATH”

Any thoughts?

Thanks


#4

I recommend getting the latest version of portainer.

docker stop portainer
docker rm portainer
docker pull portainer/portainer
docker run -d -p 9000:9000 -v /var/run/docker.sock:/var/run/docker.sock --restart always --name portainer portainer/portainer -H unix:///var/run/docker.sock

Then in portainer, you can go to the brewpi container and click to recreate it with the latest image.


#5

I didn’t even think about trying to update portainer.

Still having the same problem though.

Also, I wasn’t able to update portainer initially. It was giving me an error. I had to update the packages with

sudo apt update && sudo apt dist-upgrade

Then I was able to update portainer. However, I’m back in the same spot with this error while trying to pull brewpi:

failed to register layer: Error processing tar file(exit status 1): archive/tar: invalid tar header


#6

There seems to be a problem with portainer updating. When I update it it goes to version 1.18.1 but at some point it seems to revert back to 1.13.6 even though I used all the commands you showed above. I have tried refreshing the page, loading it in different browsers and even on my phone. They all show it reverting back to 1.13.6.


#7

Well, something strange is happening. I have stopped and removed portainer. Then I’ve removed the portainer images from the image list. Then when I reboot, docker ps shows an instance of portainer running, created 11 months ago. There is also a portainer image created 12 months ago in the image list.


#8

That’s strange indeed.
Use this to see all running and stopped containers:

docker ps -a

You stop all containers with:

docker stop $(docker ps -aq)

You can remove all non running containers with:

docker rm $(docker ps -aq)

#9

Ok, I’ll work on that.

Also, the package update that I thought helped out didn’t actually persist either.


#10

I did all that, rebooted and portainer and brewpi are running again when I do docker ps. I really hope I don’t have to start from scratch again.