Script not running / cannot receive text from python script

Running Rpi B with arduino uno Rev c. Brewpi v.0.2.10
Posted on homebrewtalk as well but no one has been able to help.
Ive been running brewpi on my chamber for about a year and a half with no issues. After my last brew I stopped my script and temperature control. Its been about 5 weeks since. I brewed last weekend and went to open a new script and temperature profile and found that it would not open a new script. My temperature profile for my last brew still shows below the graph. In the top left it says cannot get text from python script. Since then, I have updated the brewpi software and arduino from the rpi terminal but still nothing. when I reboot the Rpi I get this error that pops up:
GDBus. Errorrg.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject.

I click ok and everything seems to work.
I manually started the brewpi script from the LXTerminal and got this:
pi@raspberrypi ~ $ sudo -u brewpi python /home/brewpi/
Apr 05 2016 21:28:00 Opening serial port
Apr 05 2016 21:28:00 Notification: Script started for beer 'Citra ipa/PA’
Apr 05 2016 21:28:10 Checking software version on controller…
Apr 05 2016 21:28:11 Found BrewPi v0.2.10 build unknown, running on an Arduino Uno with a revC shield on port /dev/ttyACM0

Traceback (most recent call last):
File “/home/brewpi/”, line 415, in
File “/home/brewpi/”, line 287, in startBeer
File “/home/brewpi/”, line 273, in setFiles
File “/home/brewpi/”, line 109, in newEmptyFile
jsonFile = open(jsonFileName, “w”)
IOError: [Errno 2] No such file or directory: '/home/brewpi/data/Citra ipa/PA/Citra ipa/PA-2016-04-05.json’
Exception in thread Thread-1 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 552, in __bootstrap_inner
File “/usr/lib/python2.7/”, line 505, in run
File “/home/brewpi/”, line 72, in __listenThread
File “/usr/local/lib/python2.7/dist-packages/serial/”, line 538, in inWaiting
File “/usr/local/lib/python2.7/dist-packages/serial/”, line 464, in in_waiting
<type ‘exceptions.AttributeError’>: ‘NoneType’ object has no attribute 'ioctl’
pi@raspberrypi ~ $

Also ran : python /home/brewpi/ --kill
Killing all brewpi processes

Restarted and still would not run

Any sugguestions?

Can you try the following commands in order:

sudo apt-get update
sudo apt-get dist-upgrade
cd ~/brewpi-tools
git pull
sudo python --ask

When asked, choose the legacy_dev branch for the script, and the legacy branch for the web interface.
The legacy_dev branch is new since today, and it is a beta test of what will be released as legacy branch if no errors pop up.

cd ~/brewpi-tools
Pi@raspberripi ~/brewpi-tools $ git pull
Error: cannot open .git/FETCH_HEAD: Permission denied

run it with sudo: sudo git pull

Still having the same issue. I even tried downgrading to the .8 and .9 firmware but neither of those worked either.

I just realized that after the last update you had me do the power to temp control hot and cold are cycling on for ~50 seconds then off for ~5 seconds. I tried the kill command and it didn’t have any effect.

I think it would be a good idea to just install the raspberry pi from scratch.

The problem is not the firmware on the Arduino. It is the raspberry pi. Maybe you have SD card corruption or something is not installing correctly, but you did not share install logs so cannot tell.

Download Raspbian Lite and install from scratch.