Script not starting - brewpi spark v3


So I muddled through my new brewpi spark set up with my raspberry pi zero w. I did all this in my kitchen, where it worked, and then moved it to test in my shed fridge. Everything was working up until then but I thought the wifi signal was patchy in the shed as I couldn’t see the brewpi anymore (from time to time) using fing. I got a wifi extender for the shed and set up brewpi and pi zero on that wifi. I can see them using fing, and can log in remotely to the pi zero but I presume they are not communicating as the script won’t run on a browser.

The pi zero had a change of ip address with the move to the shed wifi extender so I edited edited config.cfg to reflect that and made both ip addresses static, then I rebooted everything but no luck.

I’m pretty much a complete noob so keep that in mind. Feels like a miracle I got this far! BUT I don’t know how to figure out what is wrong now. All help is greatly appreciated.

I actually see in the log that the ip address of the brewpi it’s looking for is wrong.
The log text
Sep 28 2017 13:54:55 Notification: Script started for beer 'My First BrewPi Run’
Sep 28 2017 13:54:55 Connecting to controller…
Sep 28 2017 13:54:55 Opening serial port
Sep 28 2017 13:55:26 Errors while opening serial port:
Could not open port socket:// [Errno 113] No route to host

I don’t quite understand most of this but as I said above I changed the config file but I changed it the pi zero ip address. Is that correct? is the old staic ip I had for brewpi which is not the actual ip address I need now.So how do I get it to look for the new ip addres?

The IP address in config.cfg should be the IP address of the BrewPi Spark, which is shown on the screen. If it is not, you should go through the WiFi setup again. Also if you can, set the WiFi to a fixed channel on your router/extender. Automatic channel switching can cause WiFi instability until we find a fix for that.

Thanks Elco.

I gave that a go but it still looked for the old ip address. SO in the end I just changed the brewpi to that static ip address in my router settings and then rebooted to brewpi and all is well.