Set up ethernet connection rather than wifi

Hello, I have just got a BrewPi up and running (using Arduino Uno and RaspPi). I noticed when I was sending the hex file to the arduino that BrewPi attempts to connect (or just ping?) an IP address using wifi, and also now that BrewPi is up and running in the error logs:

BrewPi: wifiChecker: Attempt 1 to reach failed (Tue Apr 14 17:40:02 NZST 2015)
ping: unknown iface wlan0
BrewPi: wifiChecker: Attempt 2 to reach failed (Tue Apr 14 17:40:17 NZST 2015)
ping: unknown iface wlan0
BrewPi: wifiChecker: Unable to reach router. Restarting wlan0 interface… (Tue Apr 14 17:40:32 NZST 2015)
/sbin/ifdown: interface wlan0 not configured
Ignoring unknown interface wlan0=wlan0.

I am not using wifi, just an ethernet internet connection and soon no internet connection. I am pretty sure I set up the BrewPi or RaspberryPi (or both) incorrectly with regard to wifi/ethernet.

My first question is whether this is significant, is it something I should rectify?
And if so, what should I do about it? (coming from someone with no linux or much programming background).


Hi Nathan,

Is your router configured on IP That’s the address the pi thinks it should try in order to test local connectivity. More critically, is can you reach your RPi webpage from another device in your local network? That’s what’s needed for you to view the web UI.

Thanks for your help, much appreciated.
No, to be honest I have no idea what that IP address is. It is not the router: where should I change that?
But yes I can access the RPi using Putty and access BrewPi from my laptop.
Also, I will be taking the BrewPi home tomorrow where there is no internet (!!) so maybe I won’t worry about it anyway…
Thanks again,

Great that you can access brewpi from your laptop! Sounds like you’re good to go and that error message can be ignored. I’ll add it to our backlog to investigate the message with wired connections.

When you take the brewpi home it should work fine without the internet, but if not be sure to let us know!

Hi Nathan, you can disable the wifi checker by editing the cron entry:

sudo nano /etc/cron.d/brewpi

Look for this line:
entries="brewpi wifichecker"
Change into:
entries="brewpi ~wifichecker"

And run:

bash /home/brewpi/utils/

Thanks guys.
I love what you have created, and the support!