Setting up Wifi in Hypriot [solved]


Hi, I have big problems with wifi in hypriot. I have tryed out everything in this thread and still no connection by wifi to my RPI 3.
When I run sudo iwlist wlan0 scan it finds my neighbors wifi but not mine.
No problem with network cable.
Can someone please help me.


Hi Arnt, is your network 2.4 GHz or 5GHz? The RPi 3 doesn’t support 5 GHz and neither does the Spark.


Hi Elco. I am runing my network on both 2,4 and 5 GHz.


@elco Maybe the problem is that both frequences has the same ssid?


I just tested this, because my new home setup has the same config. It works fine here. I wouldn’t expect it to cause any problems either, because the 2.4Ghz antenna doesn’t even see the 5Ghz.


@Arnt did you get this going in the end?

I flashed v1.7.1 for my Rapsberry Pi 3 and edited devices-init.yaml but it won’t update the hostname or connect to my wifi. From my reading devices-init.yaml doesn’t exist in this version and people have suggested to edit user-data. I have tried this according to this thread but still no luck.


@Dan No, I gave Hypriot up :slight_smile:

I am running Brewpi on a Jessie version and that works just fine considering WIFI and Bluetooth connection. Also this way is giving me a desktop output directly from the RPi.


as far as I know hypriot shouldn’t be necessary anymore.

docker (arm-hf) has been available in the standard sources for some time now. you can just install it on raspbian like this:

curl -sSL | s

see here: