Setting up Wifi in Hypriot [solved]


I’ve got Docker installed but I can’t seem to get it to connect to my network via wifi.

I have edited the devices-init.yaml file as instructed but when I reboot it’s not showing on the network either with Fing or by logging into the router.

When the RPi is hooked up to the router with a network cable I can find it ok. When I had NOOBS running it could find the wifi network ok.

Not sure what I’m doing wrong at this early stage.

Any help would be appreciated.


Did you remove the # symbol at the start of each line? That comments out the line.


Yes, I should have added that. I did remove all comments and #. Here is what my device-init.yaml file looks like.

hostname: black-pearl




                            ssid:"mynetwork 1"
                            password: "password"


That looks correct. Did you reboot?


Yea… almost 100 times now. lol. I dont know if this is something but when I tried:

$ sudo iwlist wlan0 scan

I get:

wlan0 Interface doesn’t support scanning : Network is down


Are you using a USB dongle? Does it show up when you run lsusb?

If I run sudo iwlist wlan0 scan it scans fine.


I am trying to use the built in wifi adapter. When I run lsusb I get this:

$ lsusb
Bus 001 Device 004: ID 04ca:0020 Lite-On Technology Corp.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Okay, so you have a raspberry pi 3.

That would be really strange if that isn’t supported out of the box by hypriot. The built-in wifi will not show up with lsusb.

I don’t know if hypriot disables wlan0 if a network cable is plugged in. I guess you already tried the obvious ifup wlan0?


When I try to connect via wifi I have the network cable disconnected and using a USB keyboard and monitor.

I’m a rookie at this so nothing is obvious to me. I just tried that and got

$ ifup wlan0
ifup: failed to open lockfile /run/network/.ifstate.lock: Permission denied

When I paste my device-init.yaml text into the tool at I get this:

(): mapping values are not allowed in this context at line 4 column 29

I cant seem to get rid of the error no matter what I do.

I’m tempted to reload NOOBS software to check on the wifi again. It would be a shame tho because I got everything else loaded, portainer and all.


I have no idea why your yaml file is not working. The linter is a good idea.

This is recognized as valid:

hostname: black-pearl

# optional wireless network settings
       ssid: "talktothefridge"
       password: "123"

I don’t know what the difference is with what you have.


Ah! It is the space after the :



Yea, I finally got rid of the error by wiping the whole thing and re-typing it. Checking it now…


Still same things show up in lsusb and its not showing up in Fing. ugh!


Your WiFi device will not show up in lsusb, because it is not a usb device.

Copy and paste my settings, yours didn’t have a space after ssid:, which I think caused all the issues.


I got a clean lint on my rewrite and even tried yours. Still doesn’t show up in Fing. My ssid has a space it in, I would assume that hypriot supports spaces in ssid names.

Well, it’s quite late here. I’m going to get some rest and see what I can do tomorrow. I may just reload NOOBS tomorrow to see if its still working there.

Thanks for all your help tonight (this morning for you).


Hope it works for you, I had the same issue of an errant space in the code. Copied from above and updated with my settings, all is good.

If you have spaces, be sure to keep the quotes from Elco’s code above.


Well, I finally got it working. I went to bed, woke up and pasted @Elco’s code and it works. I must have screwed something up when I pasted it last night. I blame it on the homebrew I was drinking at the time!

Thanks for all the help!


Hi gonzo, this is interesting for me as i have exactly the same issues, however repasting elco’s code did not solve my problem. Could you tell me which hypriot image you downloaded as i am suspicious that the image has some important bits missing for a Raspberry 3.



Hi PJ,

I downloaded version 1.5.0 from Hypriot’s blog page. I also had issues pasting code as well. Try pasting it into and see if you get any errors back. I was getting some errors that I couldn’t seem to get rid of with just editing. I ended up deleting the whole thing and pasting Elco’s code clean.


Hi, I have a RPI 2 and I did all including repasting Elco’s code too unsuccessfully. When I run lsusb command I see
Bus 001 Device 006: ID 0bda:8176 RealTek Semiconductor Corp. RTL8188CUS.11n WLAN Adapter
Is this USB dongle the problem (old)?