Settings Don't Take When Updating Devices

I am trying to update the settings for my devices in the Device Configuration of the web GUI and the settings are not saving. Below is the output from when I click Apply for each device, but the setting are not saving. Another oddity is that Function is set to None with no other options, but that could be because I can’t get the Assigned to set to ‘Beer 1’. Is that a pre-requisite?

For what it’s worth, this was working fine before, but after a power outage and reboot yesterday, I am seeing this behavior.

No installed devices found
Parsing available devices
Device list updated for null with a null shield
Device config command sent, U:{"i":"0","c":"1","b":"1","f":"0","h":"2","a":"28AA2035070000C6"}
Device config command sent, U:{"i":"-1","c":"1","b":"0","f":"0","h":"1","x":"1"}
Device config command sent, U:{"i":"-1","c":"1","b":"1","f":"0","h":"1","x":"1"}


sudo echo 'E\n' > /dev/ttyACM0

then try to set again.

pi@raspberrypi ~ $ sudo echo ‘E\n’ > /dev/ttyACM0

No go. Same results. It did however set my Mode to Off and seems to have in general reset things.

Hmm. Man, sorry I’m not much more help. I did just check and I do have options under “Function” even before I assign it.

I might try running the updater too??

It appears that there is a newer version of firmware available, which may resolve my issue, but I’m getting an error downloading it.

Checking current firmware version...
Nov 13 2015 13:15:51   Opening serial port
JSON decode error: Unterminated string starting at: line 1 column 45 (char 44)
Could not parse version number: {"v":"0.2.11","n":"0.2.11-0-ga28c22d","s":4,"y
 Current firmware version on controller: 0.0.0
Checking GitHub for latest release...
 Latest version on GitHub: 0.2.11
Version on GitHub is newer than your current version, downloading new version...
 Downloading latest firmware...
 Downloading firmware failed

*** Done updating BrewPi! ***

Yeah, that’s weird. Says current version 0.0.0?

Yeah, I had no issues updating to 0.2.11 the other day. I wonder if my power outage had something to do with it.

You could always reload and start over… Someone has to have a better idea though.

I have pretty much the exact same problem. I had an unstable power connection for a while and it seems it shut off at some unfortunate point corrupting some files.

The firmware won´t download with the same error message you get. Refreshing devices finds them all but I can´t assign them to anything because the lists and settings are returned empty. No doubt because the programs can´t figure out the version of the shield.

I get this message in the output when refreshing devices:

Device list updated for null with a null shield 

Did you manage to solve your problem? I suspect upgraded firmware would go a long way towards solving it but I don´t know any alternative way of doing it.

I haven’t solved it yet, but was thinking about reinstalling Raspian tonight and completely starting over. :frowning:

I actually just solved it on mine. Completely baffled me. The error seemed so far into the versioning of the firmware I didn´t even consider the easy fixes.

I simply did a reset with a pin in the reset hole on the back of the Spark…

Good luck. Hope yours will be as simple as mine.

Wow! That did it! Thank you. That saved me a lot of time. Everything is working again.