Socket attached to SSR gives always power

Hi there
I made my system like in the schema attached. My problem is, that the socket, where I attach the solenoid valve gets always power and the solenoid valve is switching on and off even when the SSR is not on (no active LED). The solenoid valve is 24v DC but powerd with a 220V AC adapter like in the picture.
When I put a normal lamp in to the socket, it works fine. When SSR is on the light is on, when SSR is off, the light is off.
When I use the solenoid valve with the adapter with an Inkbird it works also fine. So it must be something with the spark or SSR.
Thanks for your quick help.
Cheers, Dani

1 Like

Is the 24V solenoid connected to the SSR, or directly to the Spark?
Could you please measure the socket voltage and amperage with SSR on and off?

Hi Bob
The 24V solenoid valve is connected to the ssr, via a socket and the 220v power adapter which have an 24v output to the valve. I tried to draw that in the schema picture.

Is the SSR from BrewPi Store? I had the same problem when I used cheap SSR from Fotek. Newer had a problem with them from BrewPi Store.

Yes, I have everything from the BrewPi Store.

I’ve got always 230 V on the socket.

Now the SSR stopped working at all :-/ No LED when it should be on.

That sounds like a wiring issue. I asked Elco to take a look at this, as hardware is not my area of expertise.


Did you already got feedback from Elco?

Measuring 230V on the socket with no load is normal, because the SSR has a resistance in the mega-ohm range when off. But as soon as you give it a load, you should be measuring no 230V on the output.

The load from a valve will be very small, but I would still expect it to be enough load for the SSR. It does sound like a defect. To switch 24V valves, I would recommend using a DC SSR and placing it between the 24V power supply and the valve.

A good test would be to power your valve from the heating SSR.

Thanks Elco. But the funny thing is, that when I plug a normal lamp into the socket everything works fine, on and off with no problem. But when I plug in the 230v to 24v adapter for the 24v solenoid valve, the valve is opening and closing every second. When I try the same with an Inkbird (same adapter) the valve is working just fine.

I already tried it to plug in in the socket for the heating element (so the other ssr). Same behaviour. So I think it can not be a defect.