Software Install Guide


#65

I'm not sure if this helps but i had a similar problem when setting up my RaspberryPi as the web server. The only way i could get it to run was to have the install in the folder /var/www/html/ if it was in /var/www/ it wouldn't run. I only had this problem when i set up the Pi as a web server following the instructions given by the RaspberryPi foundation. After formatting and re-installing using Elco's set up guide the insatll would run from the /var/www/ folder.


#66

here is the output when i run "-ahl /var/www/

hope this gives you guys some clues!

thanks again

travis


#67

also, i now have the Pi plugged into an ethernet cable at IP address 10.0.0.6. I know the error above that say the IP address is 10.0.0.11. I am getting the same error message however, with the Pi plugged into the ethernet cable,

-Travis


#68

Ok, in

sudo nano /var/etc/apache2/sites-available/default

sudo nano /etc/apache2/sites-available/default

Does it say DocumentRoot /var/www ?
If it says /var/www/html/, please change it.


#69

when i type in

sudo nano /var/etc/apache2/sites-available/default

i get this response, no sign of /var/www/html

???

Travis


#70

Ok, looks like you are opening a new file.

Check which files are available by autocompleting with tab. It is probably called something like 000-default


#71

hey Elco,

i enabled autocomplete, when i do autocomplete after entering "sudo nano /var/" i only get a new buffer, here is a screenshot:

so it seems like the web directory isn't installed?!

if you need any more info, let me know...not really sure what is going on

-Travis


#72

hey Elco,

so i re-ran "sudo ~/brewpi-tools/install.sh"

when it asked "what should be the path to your web directory for brewpi? [/var/www]:" I put /var/www/html

now, when i type the ip address of the raspberry into my browser, i can see the brewpi web interface!!!

not sure why adding the "html" works, but it did, any input?

thanks,

Travis


#73

Apache was configured to look for files in /var/www/html/, so I asked you to change the configuration to look in /var/www/

sudo nano /etc/apache2/sites-available/default

I have given you the wrong location for the config file before, sorry.
Now that you have installed the files in /var/www/html, the default configuration works.


#74

Hey Elco,

Now that i have the web interface working, the raspberry pi doesn't seem to recognize the brew pi spark when i attach it via USB-USB mini cable.

I've read in previous posts that some USB cables just don't work. Any recommendations on a reliable USB-to-USB Mini cable that does the job?

-Thanks


#75

I suspect the USB connection is fine, but the connection between script and web interface is not, because it is not in the standard location.

In /home/brewpi/settings/config.cfg, make sure you have the line:

wwwPath = /var/www/html

#76

hey Elco,

i checked in "home/brewpi/settings/config.cfg" and "wwwPath = /var/www/html"

when i run "sudo ~/brewpi-tools/updater.py" to update my controller, i get this screen

and "unable to connect to controller"

stuck again frowning sorry for all the questions, but i am somewhat of a noob here....

I also tried the "sudo -u brewpi python /home/brewpi/brewpi.py" and got this:

and tried "ls /dev/ttyA*"

not really sure what any of this means, can you help some more? Where/how do i install the script?

Travis


#77

Hmm, that does sound like you are unable to find the device.

If it is not in the list while you run ls /dev/ttyA*, that does sound like it is not connected via USB.
What is on the BrewPi screen? Are you sure you have fully pushed in the USB cable?


#78

here is my brewpi screen:

i have one thermocouple in, i have pushed both ends of the usb cable in well


#79

so i plugged the power cord for the raspberry pi into a different USB slot in my docking station, and now this screen pops up on my BrewPi

so maybe my power supply isn't good? why would i be getting 2 different screens?


#80

oh, and with new screen on brewpi, still can't connect to any serial ports


#81

Are you powering the raspberry pi from a docking station? Do you mean USB hub?
It could be that the raspberry pi and brewpi are not getting enough power.

Can you try plugging the brewpi into a PC and see if it shows up in device manager?


#82

I am starting to wonder whether the latest version of Rasbpian has drivers for the Photon.
I will try a full re-install this weekend to see what's up.


#83

ok, haven't other people already done this install w/ the photon? I can't be the first, right?


#84

Elco,

good news! I upgraded my RaspberryPi power supply to a 5V/2A, and put in a "better" USB-USB Mini cable between my Raspberry Pi and Brew Spark, now the script loads!