Software Install Guide


#45

You need to put it in Dfu mode by holding the mode button while plugging in the USB. If it is in the enclosure, this is the hole closest to the Dutch flag. Release the button when the LED is flashing yellow.

Then run:

sudo python /home/brewpi/utils/flashDfu.py

#46

Thanks Elco , appreciate your promot response, i tried how you suggested, got this error:

pi@raspberrypi /home/brewpi/utils $ sudo python flashDfu.py
Downloading latest firmware...
Latest version on GitHub: 0.3.0a
Could not find download in release 0.3.0a with these words in the file name: ['spark-core', '.bin']
Downloading firmware failed


#47

after using updater.py to upgrade the script I was able to run flashDfu.py but now it is stuck at "opening serial port" step


#48

Try a different USB cable. Sometimes the cable gives power, but not data. Also ensure it's inserted all the way.

I had this a few days ago working on a photon - wouldn't detect DFU on my mac. I tried all the "smart" things first like disconnect/reconnect USB, rebooting, before I checked the cable.


#49

Not sure if this is the best place to post this, but I don't think that I have rights to post a new topic as a new community member, so here goes.

My IT background is more in network design and server implementation and even that is 10 years old at this point. While back then I used Linux a bit for some Apache servers and some other functions I was never a Linux/Unix guru by any stretch.

I would like to set up a BrewPi system on a new Ferm chamber (fridge hack) that I am building. I have put STC and PID control panels together so I am pretty comfortable with all of the wiring that needs to be done, and I definitely grasp the concepts of how the Ras Pi works with the config. I am however concerned about the actual implementation of the software. If I have to start monkeying with the config files I am not sure that I have the chops to get through it without step by steps. I can however follow directions and it seems like many get through the new spark implementation without issue, but then others run into problems.

The end result is a question - Can someone with basic tech knowledge but without linux or coding knowledge get through this without pulling all of their hair out?

Thanks!
Russ


#50

@RussPDX I have a good friend who is by profession a CPA so has 0 *NIX skills and he was able to fly through the build/install. With the little knowledge you do have of *NIX even old should be more than enough to get you through it and if you do get stuck you can always come here and ask.

Cheers,
-Stephen


#51

@sunadmn Thanks for the vote of confidence. I think that I am going to give it a shot. Just need to save a few extra dollars so that SWMBO does not have my head. I have read through the post several times and think that I am good on getting the RasPi setup with BrewPi but it does not seem to go into connecting the Spark. Is that detailed somewhere? Am I just missing it? or has it not been written yet? It also seems like it has to be hard wired at this point together. Am I understanding that correctly? From my read there may be a future wifi release to connect the two but that is not available at this time.


#52

That is correct. It is USB now, mainly because TCP was unreliable with the Spark Core. With the Photon (and the Spark Core after a deep update) it should be a lot better. WiFi will come in the future, but I am focussing on PWM/mash support first myself.


#53

Good evening.
I just recently bought two BrewPi with the new Photon, shipped with 0.2.11 preinstalled. I'm supposed to help two colleagues setting them up, ready to be implemented in their fridge.
Earlier this year I bought a BrewPi Core, which I upgraded to 0.2.10, and runs smoothly.

I am now having trouble getting these two Photon to run.
At first there were no connection via USB (using RPi2), I then found the BrewPi was recognized as ttyAMA0 and added this in the config.cfg file and with no second alternativ added (as there were no more listed)

I then restarted the Pi, got connection, and script was running.
The next step for the Pi seems to be "Checking software version on controller..." This fails!

stderr-log from web-interface

Sep 21 2015 22:12:24 Opening serial port
Sep 21 2015 22:12:24 Notification: Script started for beer 'My First BrewPi Run!'
Sep 21 2015 22:12:34 Checking software version on controller...
Sep 21 2015 22:12:44 Warning: Cannot receive version number from controller. Your controller is either not programmed or running a very old version of BrewPi. Please upload a new version of BrewPi to your controller.

I then did an attempt to run ~/brewpi-tools/updater.py with this result:
######################################################
#### ####
#### Welcome to the BrewPi Updater! ####
#### ####
######################################################

Checking whether the update script is up to date
/home/pi/brewpi-tools is up-to-date.

*** Updating BrewPi script repository ***

Stopping running instances of BrewPi
You are on branch master
The latest commit in /home/brewpi is 4c7dfa342d8403eb2b485e9970e2cdec9e53c9e4 on Wed, 05 Aug 2015 23:15:44
The latest commit on origin/master is 4c7dfa342d8403eb2b485e9970e2cdec9e53c9e4 on Wed, 05 Aug 2015 23:15:44
Your local version of /home/brewpi is up to date!

*** Updating BrewPi web interface repository ***
You are on branch master
The latest commit in /var/www is d44c03e786d0bde0dc43f86a8bd655659f3f3d2b on Wed, 11 Mar 2015 22:59:39
The latest commit on origin/master is d44c03e786d0bde0dc43f86a8bd655659f3f3d2b on Wed, 11 Mar 2015 22:59:39
Your local version of /var/www is up to date!

No changes were made, skipping runAfterUpdate.sh.
If you encounter problems, you can start it manually with:
sudo /home/brewpi/utils/runAfterUpdate.sh

The update script can automatically check your controller firmware version and program it with the latest release on GitHub, would you like to do this now? [Y/n]:
Stopping any running instances of BrewPi to check/update controller...

Checking current firmware version...
Sep 21 2015 22:16:38 Opening serial port
Unable to connect to controller, perhaps it is disconnected or otherwise unavailable.

*** Done updating BrewPi! ***

I'm a bit lost now, and don't know where to go from here!
I would really appreciate some guidence.

-Ove


#54

AMA0 is not the Photon. It is the internal RS232 port of the Raspberry Pi.

The latest version of BrewPi automatically recognizes witch port the Core/Photon/Arduino is on, and I recommend leaving the port setting at auto.

To see which devices are found, you can run the serial port detection separately:

pi@brewpi ~ $ python /home/brewpi/autoSerial.py
All ports:  (('/dev/ttyACM0', 'ttyACM0', 'USB VID:PID=2b04:c006 SNR=00000000050C'),)
Compatible ports:  (('/dev/ttyACM0', 'Particle Photon'),)
Selected port:  ('/dev/ttyACM0', 'Particle Photon')

This is what it should look like. IT has found only one serial port and it has recognized it as compatible and has it auto selected.

If no ports are found, it might be the USB cable. Try if a PC with the same USB cable does recognize the device.


#55

Thank you Elco, that worked.
I think I know what got me into this problem. I most likely had a bad USB cable at first. Then I only saw the internal RS232 listed.
Yesterday I bought a new USB cable, but I did not remove my faulty setting in config.cfg. So it would still try to connect to AMA0.
After swithcing to auto and a working cable, all is fine.

Looking forward to set up the last BrewPi now smile


#56

Just wanted to report back and thank everyone. The RasPI and Spark are set up and BrewPi is all installed and appears to run correctly. Little hiccup in getting on my wifi but a Google search or two later and all good. Just need to finish up cleaning up the fridge and wire in the relays. Once I have a chance to sit with the fridge hack diagrams and my fridge diagram I will probably be back with more questions.

For anyone else without RasPi or real Linux or coding experience, this is not a big deal if you can follow instructions.

Russ


#57

Hey guys, I'm a bit jealous of those who have found the setup of rip and bpi easy!

I'm about 5 hours in so far, and have a really shaky wifi connection on the Rpi (works for a while then dies), and have managed to get most of the way through the instal script but it failed trying to access github.com when it was getting the latest codebase.

I'm trying to run the script again, I hope this is the right thing to do?... but now I am unable to access github.com - I can access help.github.com and others, and every other website in the world... but not git hub. I have the pi plugged back into my router now to avoid any wifi issues.

If I turn my iPhone's wifi off and get onto 4G network, I can access github.com just fine. Has my IP address been blocked from accessing github or something? ISP blocked it for some reason?

I'm not going to lie... I'm really upset at myself for going down the Brewpi route this afternoon. I'm thinking I should have chosen the BCS 462 which required a lot more wiring and electrical engineering (skills I have) and a lot less IT bullshit. but this mainly comes down to my limitations smile

If anyone is kind enough to try and provide me some help, please cutback on the jargon! Cheers.

Also @Elco have you considered updating the documentation on the homepage to reflect this post? I followed the guide in documents, then discovered static IP was not necessary, and a few other variations... Just a point.

EDIT - SEMI SOLVED. I got lucky and scored a 10 minute window where my rpi would connect to github. My macbook still won't go anywhere near it!!!!! Meaning I was able to finish the script, and my setup is now working. Planning on doing a lot of reading tonight before trying to see what I can do with a single pot of water tomorrow.

Another point specifically relating to install guide... Step 4 in the documentation section of the homepage is no longer required right? I skipped it and everything works fine... It might be helpful for those who are really not up to speed with this stuff if it was removed? just to save some confusion?

I would still love some help if anyone knows why my ability to get into github is stuffed?

And Elco, if this post is not appropriate in this topic anymore pls move... its a bit off topic I guess? sorry.


#58

Glad you got it to work now! Indeed, step 4 is not needed, because the Spark has already been programmed.

If you are using Safari, you need to change a setting in the web server to make the web interface connect reliably. This is due to Safari not conforming with web standards.

Open the config file in nano:

sudo nano /etc/apache2/apache2.conf

And find the keepalive timeout and set it to 99

KeepAliveTimeout 99

Save the file, then restart apache:

sudo service restart apache2

Not being able to reach GitHub sounds like it was related to your ISP or GitHub itself, because it was not working on your Macbook either. I would not worry about it now and just hope it was a temporary issue.


#59

hello everyone,

i have been somewhat successful in setting up the raspberry pi and brewpi spark, however, i get to the end of the above instructions, and when i try to access the spark by typing the static IP address of the raspberry PI into a web browser, i can't access the spark!

Any idea why? This whole setup is getting kind of frustrating!

thanks,

Travis


#60

Ok so walk us through the steps that you did and let's see if we can figure out where things went wrong.

Also any errors messages will greatly help.

Cheers,
-Stephen


#61

thanks,

ill recount the steps as best i can. so I went through the startup instructions, installed raspbian, believe i reconfigured the network settings ok. here is a screenshot of how i configured the raspberry pi's static IP address.

Inline image 1

basically i configured the raspberry to an IP address of 10.0.0.11. Once i did this, I installed Putty (i am using windows), and was successfully able to log in remotely to the raspberry pi using it's static IP addresss. I was able to ping google as well, just like in Elco's instructions.

Next, I installed BrewPi using the commands in Elco's instructions, and everything went smoothly. At this point, I think that i should be able to access the web interface by typing the Pi's IP address into my web browser, but when i do, i keep getting this error from the browser...

Inline image 2

It says the "requested URL/ was not found on server. it seems to recognize that the server is a Pi, but won't show the brewpi interface,

this is where i am stuck,

any help is greatly appreciated,

thanks,

Travis


#62

sorry, here is a pic of the error message that keeps popping up...i even wiped the SD card on the raspberry pi and start instructions from the beginning and keep getting this error! what is wrong! All i want to do is brew but i'm wasting all my time trying to set this dang thing up!


#63

What is in your /var/www/ directory?

It looks like the web server is working, but the files are not there.

Can you post the output of

ls -ahl /var/www/

#64

Yeah as @Elco said the webserver looks to be up, but the files might be missing for some odd reason. If you could run the command he suggested that will help us figure out what might be going on.