Software Install Guide


#23

@Alessandro: we disabled spark cloud functionality because we need the extra space and because we have a local server. It is normal to not be able to access the core via the Spark Cloud.

You have to connect the BrewPi Spark via USB. I see that you are connecting to COM5, so you're on Windows.
On Windows, you'll have to manually start the python script and configure the config files so the web interface and python script can find each other. More info is given is this thread:

@kekich:
SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data"
That's just the error you get when the script is not running at all, we should add a better error message when people try to receive devices but the script is not even running or does not respond at all.

Are you sure you have an internet connection and can resolve DNS? It is strange that you cannot find the psutil package via pip.

Also, please skip updating the spark core in the install script, it is not implemented yet. I am fixing that this week.


#24

Im having some trouble connecting the spark over usb as well. Do I have to connect to my mac first to configure it with a program like cool term? or can i connect via ssh on my terminal?


#25

The spark is connected to the raspberry pi via usb. As soon as you connect it it should power up.

You communicate to the spark through the web interface, which is run by a server on the raspberry pi. Does this help at all?


#26

unfortunately is does not. the web interface says it cannot run the script. im unsure if i need to assign a hex or claim the spark or anything else i missed


#27

Hey Robert. Are you using the RPI? If so have you updated the BrewPi software? The update allows the RPI and Spark to communicate over a serial port. I see it says script not running, have you tried starting the script? (By clicking script not running)


#28

Check if the device is actually seen by the Pi: ls /dev/ttyA*
Another user reported that his USB cable did not make contact with the data pins, but did power the device. He had to push it in further to get a serial port.

You can also come to store.brewpi.com and click chat, I'll help you out.


#29

i have almost certain i updated the pi but i cant try up update it again its possible i missed a step. and yes i did click on the run script button and it does nothing. it doesn't recognize any devices either.


#30

This is what comes back when i type that command in

/dev/ttyACM0 /dev/ttyAMA0

i wont be able to check the cable until tonight though. I'm hoping this is the case.


#31

Okay, looks like you have a serial port. What do the log files say? Why is the script not starting?


#34

got it to work, i need to reinstall and update everything again


#35

I've reset my Spark and I'm trying to install Brewpi on windows using COM5:

  • If I run updater.py I get this error

    Traceback (most recent call last):
      File "updater.py", line 335, in <module>
        if os.geteuid() != 0:
    AttributeError: 'module' object has no attribute 'geteuid'
  • If I run brewpi.py I get

Error opening serial port /dev/ttyACM0.
(could not open port '/dev/ttyACM0': WindowsError(3, 'The system cannot find the
path specified.')):
Error opening alternative serial port /dev/ttyACM1.
(could not open port '/dev/ttyACM1': WindowsError(3, 'The system cannot find the
path specified.')):

It's been now a week since I've completed and successfully tested the refrigerator. The only thing that's keeping me from brewing is the configuration of Brewpi cry


#36

Hi Allesandro,

The update script is really meant for use on a Raspberry Pi, or at least Linux.
On Windows, there is no such thing as UID (linux user's id, coupled with permissions).

You will have to update the web interface and python scripts yourself by doing a git pull.
Sourcetree is a visual client that might help you with that.

To update the controller, you can run updateFirmware.py from <script dir>/utils


#37

Ah!

It was just me being dense: I was trying to install the software on the Arduino. I am now able to brew some beer.

Thanks Elco!


#38

Had some issues connecting my Edimax wifi dongle to my AP which was using a hidden SSID.
Solved it after a bit of googling by adding the following to my /etc/network/interfaces

wpa-ap-scan 1
wpa-scan-ssid 1

This also works using a wpa-supplicant conf file with ap_scan=1 and then scan_ssid=1 in the network section. Hope this helps someone, now to finish my fridge and get brewing


#39

Just found out that the latest images (at least the NOOBS image) comes with zeroconf pre-installed.

The raspberry pi will announce itself as raspberrypi.local on the local network. Messing with static IP address is therefore not needed. I have updated the guide.


#40

Do you have a pic or sketch of the different wiring method you had to use? I have a SainSmart board and relay as well.


#41

Why is Raspberry Pi still needed for Spark Core version of Brew Pi as it has its own Wifi and cloud connectivity? Why can't I run server code on my remote web server?
Any recomendation what needs to be changed for this to work?


#42

As far as I know ...

  • The cloud connectivity is not available on the Spark, once the BrewPI firmware is installed
  • You can easily run the server on another linux computer, following the same instructions as with the RPi (don't know about other OS's)
  • I think the wifi connectivity in the BrewPi Spark firmware is still not done, so you have to connect the BrewPi Spark to the server by USB

#43

What Brian says is correct.
On the Spark Core, there is not enough room for the BrewPi code and the Spark Cloud code together.
On the new Photon, there is plenty of room and it should be possible to expose variables into the Spark/Particle cloud.

We have not coded Wifi connectivity yet, but the plan is to make the USB link and WiFi link interchangeable.
The Pi is just used as a web server, there is no real reason you couldn't use another server.


#44

Hi Elco,

I did purchase brewpi spark couple months ago, everything was configured properly and working fine until i had to reset the device because it was undetected on my raspberry interface. i did reset the device using my windows box after manually installing the driver and using particle io cli.

Once again, a day before my brew day, I did reset it again accidentallyand since then i am trying to connect it through windows or wifi, no luck so far. Blue light is flashing but still device is not detected on any of the computers

Please help me, it feels like my purchase is going to be wasted.

-Gaurav