[SOLVED] Brewpi on debian jessie, cant access web interface

Hello, I run the install script for brew pi and accepted all of the default options. it seemed to install ok.

My arduino is still in the mail so I was just trying to play around with the brew pi interface before the arduino got here.

I added the command to the crontab and restarted cron…

when I type my ip address into the browser it tells me it is not found.

I am pretty sure that apache is running.


1 Like

OK so I was able to get into the web interface. apparently the way apache is configured on my machine. all files must be in /var/www/html directory.

so I just made a soft link in /var/www/html to every file in /var/www. This allowed me to get into the brewpi interface with the browser.

not a fix but a workaround…

I guress I need to learn how to configure apache2 so that the expected location is www.

one more update for anyone else who happens to be as supid as I am…

I found the config file for brewpi and was able to change the wwwpath to /var/www/html.

the right thing to do would be for me to take the time to learn how to configure apache and proeprly set that up but Im to busy/tired :frowning:

Ok I was having a heck of a time figuring this out but I finally did. If you are having an issue with the webpage not popping up after your initial install change the apache2 000-default.conf file which is located at /etc/apache2/sites-available. Edit the DocumentRoot /var/www/html line to read DocumentRoot /var/www Do not clone the www files into the /html file like I did you will not be able to log anything and any new profiles you create will not work either. Hope anyone else who is having this issue will find this.

Thank you so much for posting how you fixed this issue. You saved me 2 months of research :wink:

I did the installation process a few times without any problems, so I could not figure out why the web server/interface was not showing up in the browser.

Can someone make a screenshot or type exactly how to do this. I am not good at this raspberry stuff and i lost conection to brewpi user interface. Can ping it and see it via Fing.

Solved it with the advice above, thanks!
My problem now is that i can’t se the userinterface when accessing from remote. On top left it says: SSh-2.0-OpenSSH_6.7p1 Raspian-5
Any good suggestions on what to do to get the userinterface up and running from a remote location. Works well from local. Thanks

Dude! I had this exact problem and this was precisely the solution!!! Thank you SO SO much! If I could, I would hug you right now lol!

Cheers, and thanks again!

How do you save it after you edit. It’s opening with LibreOffice Writer. Sorry this is all very new to me.

Don’t open it with the LibreOffice Writer. You have to open it with superuser permissions. Take the console and open it with “sudo nano filename”, edit it, save with Ctrl+O and Return and then press Ctrl+X to close.

In the Terminal I put sudo nano filename. Then it turns into GNU nano 2.2.6. File: filename not really sure how to use this program. Sorry again! Thank you for the help.

I’m having a hard time trying to finding where the file is that I need to edit. Thanks for the help.

Try the following:

sudo nano /etc/apache2/sites-available/000-default.conf

This worked for me getting it all up and running!

Thank you so much!!! Worked perfectly!

Thank you. Now I can sleep.

So I have had the same issue being new to raspberry and spark. When I try and load my address to the Pi I get the Apache2 Debian Default page.

You said you found the Apache directory and reprinted files and such.

This sound really complicated to me. How do you do that or am I completely missing a step somewhere on this install?

Never mind. I went through each of the manual install steps and figured out my issue to get the interface up and running. My issue ended up being no permissions to delete the HTML file in the WWW directory. I did research how to superuser delete the file and the script ended up loading afterward. But that was for that specific permission.

My only issue is permissions within the raspberry pie not given me the rights to overwrite and delete certain files. If you could help with that it would be awesome. Or if you could direct me into looking on how to do these different permissions.