[SOLVED] RPi fails to boot - Help


The first time I tried this build, it worked flawlessly except I did not run the permission fix, and therefor could not change or edit the beer profile. The only way I could move the rpi to a monitor was to unplug it as I putty was not working. In doing so, the Pi corrupted.

Here are my steps exactly:

I reformatted my microSD card with the SDFormatter utility. I downloaded NOOBS 1.4.1 and installed. I ran the update, upgrade, and rpi-update and rebooted after each. I cloned the git hub and installed using the commands provided on the walk through. After the install, the web interface is up and running. I reboot, and the pi fails.

2015-09-04_04-32-58 by Mark E, on Flickr

I don’t understand why it worked so easily the first time, and now this is my second day and 4th attempt to get this to work.

The only thing I can think of are the updates and the arduino. Are the updates too new and therefor causing a problem? Does the arduino need to be connected?

I suspect this has happened every time because when I move the rpi after all the installs to the fermentation location and connect it to the arduino, nothing happens, no internet, nothing. I do not have a spare monitor to move with the pi, unfortunately, and with no internet, no way to run putty.

Any ideas? I’m going slightly bonkers.

Are you using an SD card that is in the verified peripherals list?

Are you powering the pi with a 2A power supply and not for example a phone charger?

Does it boot without the arduino connected?

Did you try rebooting on the location that didn’t give you problems?

Instead of putting noobs on the SD card, put Raspbian on it directly. Much easier. If your problem is boot record related, you’ll avoid that too.

I do not know if the SD card is on the verified list. I’ve used it without issue the last year or so. I will check tomorrow (I have to pick up my mom at the airport in about 5 minutes).

I am powering it with a 2A supply, but it also happens to be a phone charger.

It will not boot with, or without the arduino.

I have tried rebooting in both locations with the same outcome.

Brewpi worked flawlessly for 2 weeks prior to this attempt to fix permissions.

Thank you so much with your expedient reply!

Here is the list to check your SD card: http://elinux.org/RPi_VerifiedPeripherals

I am very wary of phone chargers for the Pi. Especially cheap ones.

If you are going to try again, skip NOOBS. Try rebooting before installing brewpi to rule that out.

Try this order to where it fails:

  • Put Raspbian on SD card
  • Boot
  • Reboot
  • Expand root partition
  • Reboot
  • sudo apt-get update; sudo apt-get dist-upgrade
  • Reboot
  • Install BrewPi
  • Reboot

Also, when installing BrewPi, do you just accept the defaults by pressing enter? Or are you changing the install location?

Kingston 16G Class 4 - Verified

I’m using the charger from my last phone, Galaxy S4. I will get a legit power source.

I accept the defaults. Including the bit about restarting the wifi adapter if it looses connectivity.

I will try again tomorrow and report back. Thank you so much!

I followed the steps as described and so far, the Pi has survived two reboots and a shutdown. Next, I’ll try moving it to the fermentation location.

As always, thank you.