<Solved (sort of) >Can only access web interface with iPhone or iPad


#1

I’m stumped in trying to solve why I cannot access the web interface from my pc (site not found or timeout error occurs). Oddly enough, i can access the web interface just fine with my iPhone and iPad (script shows its running and all is well). Things i have tried so far:

  • accessing the direct IP address vs. raspberrypi.local
  • Two different pcs
  • Internet explorer vs.Google Chrome vs. Mozilla. Internet explorer will pull up the web interface but in the box where it would say ‘script running’ its blank with a red outline and i can not view log under the maintenance panel. Google chrome and Mozilla will not pull up the interface at all
  • Downloaded Safari for the pc but it wont pull up the interface either.
  • Cleared cache, cookies, etc.
  • Edited /etc/apache2/sites-available/000-default.conf - to remove html from the DocumentRoot line

Any ideas as to what im missing? This had not been an issue until i did an update.

Thanks for any help,
Matt


#2

Update. The IP address changed which was causing the issue. I still dont why i have to type in the actual IP address vs. raspberrypi.local on the pc as opposed to the iPad. Weird.


#3

You either don’t have it installed or disabled the service on your PC. You can install iTunes or just the specific (EDIT typo) software to test.


#4

.local addresses are managed by mDNS, also known as zeroconf. You need to have it installed on the pc. Possible implementations are bonjour or avahi.