[Solved] Spark can't read temp probes (even w/ successful hardware test)

Dear BrewPi community,
I just tried updated my BrewPi Spark to 0.4.2 and I’m having the following trouble:

  1. The controller doesn’t display the temperature readings of any of the temperature probes that are plugged into it.
    –> 1a) The firmware test menu DID display the temperatures of all 3 probes that were plugged into it. After turning on the web interface script, none of the probe temperatures are displayed on the controller graphical interface or the web UI.
    –> The controller does display the setpoints that I put into the web UI (fridge temp & beer temp), so it does seem like my RPi and my BrewPi Spark are communicating w/ each other
  2. I ran flashDFU.py properly already (that is - I ran flashDFU.py after setting my Photon to DFU mode per this guy).
    –> https://docs.particle.io/guide/getting-started/modes/photon/


Did you assign the sensors in the device manager?

Ahh, there we go! Looks like that’s all it was :). The device manager page wouldn’t load for some reason, so I thought that something else may have been wrong.

Thanks Elco :slight_smile: !