Spark Flashing Rapid Green

After reading some search results it seems this means it is trying to connect using WIFI. Seems whatever I do it’s not connecting. Says I’m running the current firmware with the build date 2022-01-21T18:50:12.516Z. If I go into my dashboard, then ADMIN, configure wifi, and put in my router’s SSID and password, it gives me a green message box that says WIFI setting updated. Do I then reboot the controller ?? It also showing for the IP address at the top of the spark display

I’ve made no changes to my system… Any ideas ??

Thanks in advance !!!

As an alternative, you can run brewblox-ctl wifi with the controller connected over USB.

To completely wipe all stored credentials first, hold the SETUP button until the LED blinks dark blue, and continue holding it down until it the LED starts blinking rapidly. This takes 10 seconds.
The RESET and SETUP buttons are in holes on the right side of the Spark 3. The sticker on the back indicates which is which. I find toothpicks to be most convenient for them.

I did the reset, got the blue flashing led, setup the wifi, and I’m back to the green rapid flashing led.

And now seeing this ??

Could you please run brewblox-ctl log?

Just ran brewblox-ctl log. the handshake is now normal as is the synchronization.

1 Like

To verify: the Spark has an IP address again, or is it now connected over USB?

Still has all zero’s for the IP. shows USB is connected.

I can see my dashboard and temperatures.

The Spark 3 supports both USB and Wifi, so right now it’s functioning as normal - but without Wifi.

Have you double checked the SSID and password you’re using?
How good is reception where the Spark is?
If you set up a different Wifi network (for example, a hotspot with your phone), will the Spark connect to that?

Running brewblox-ctl wifi in Putty (SSH) does strange things. Says to enter “w” and when I do most times nothing happens. then other times it spits out numbers and letters…

I’ll try that in the morning. The spark is 15’ from the router. Same wireless router I’m using now.

The router should be ASUS_53_REPETER

Are services stopped when running this? Could you copy-paste or screenshot these numbers and letters?

Tried to connect to my phone, Same result, rapid flash grenn led

Just configured back to my wireless router and restarted services and it connected…
Slow pulse and it has an IP address.

1 Like