Spark IP address

Good morning

I have updated my wifi at home and the ip range is now different. Please can you let me know how I update the ip on my spark to be able to communicate with the new ip range.

Thanks in advance

If simply restarting the Spark doesn’t get assigned a new IP address, you could try resetting wifi credentials by first connecting with a wrong password, and then again with the correct password. (Spark service actions)

If that doesn’t work, you can reset wifi credentials by holding the SETUP button on the controller until it rapidly blinks blue. Then use the Particle app or USB to reconnect to wifi.

Hi Bob
Tried all of those and ip now
If I reset of the sparks, will that give me the ability to reset the wifi?
Many thanks

I’m not sure what you mean with “reset of the sparks”.

Have you reconnected to Wifi? (connect the Spark over USB, and then use “Configure Wifi” in the Spark service actions).

I ran configure wifi, set new name and password through Brewblox - while connected over usb, but the spark still shows ip of

So am rather puzzled

Many thanks

1 Like

You can double check whether you entered the right SSID/password info/security settings.
If that doesn’t work, try rebooting the controller.
If that doesn’t work, hold the SETUP button until it rapidly blinks blue to reset wifi credentials, and then reboot the controller.
If that doesn’t work, download the Particle app, and follow their instructions to connect to a Wifi network.

Done all except particle still nothing.

Can you include the link for particle app please?

Many thanks


Brilliant, many thanks

Hi Bob
I have managed to update ip addresses on all sparks, but now only 1 has the service start in Brewblox the other 2 have the following message:

Not sure what I have missed

Are you using --device-host in your docker-compose.yml? You can run brewblox-ctl log to check.

Yes it seems so, how do I remove them?


Use brewblox-ctl add-spark -f -n [name] to overwrite, and pick the same device ID as previous. If mDNS discovery still doesn’t work, use the --device-host argument with the new IP.

Many thanks Bob

That worked a treat