Spark keeps beeping endlessly


I’ve just received my BrewSpark, and was trying to set up a couple of temperature probes. Now whenever I power up the Spark it beeps at me endlessly and erratically, - it almost sounds like a '90s modem.

Is there a way to turn off beeping, or will I need to reset the Spark?

I’ll like to help find the cause of this via chat or screen sharing.
Please come to the store chat or IRC and I’ll give you some one on one support.

1 Like

Interestingly the beeping only happened when the Spark is plugged into my laptop. Now it is plugged into my Pi there is no problem.

I’m also having this problem. The beeping seems to change in tone and frequency when I send signals to the BrewPi via the webapp. Any word on what may be causing this issue? I know the USB ports it is connected to are 3.0. When I plug into the 2.0, the screen won’t even come on.

Can you try powering it with a USB power supply for a phone? When this problem occurred in the past, it was caused by the PC sending random data to the Spark. The alarm can be turned on and off by sending A/a, which might be what happens here.

This was happening to me, but the beeping goes away when powered via a usb phone charger. Can the Spark work autonomously like that? i.e fire the ssr’s? or is that done by the script on the webserver?

The Spark runs the control algorithm autonomously. In fridge constant mode or beer constant mode, it does not need the web server. Temperature profiles are managed by the pi though, it is just like beer constant mode, but the pi sends setpoint updates.

I suspect your PC is sending an ‘a’ over serial, which enables the alarm. I don’t know why that happens. Maybe due to a bad USB cable or the board is not getting enough power, which caused data corruption?

Can you can try powering the board with a 12V power supply or using a better/shorter USB cable?

Hi, I have tried a few USB cables and they all were the same - when the USB isn;t connected and its only powered by the adapter, its silent. BUt as soon as you plug in he USB its starts beeping again. BTW, I’m using a PC running Linux.

Is there a command I can use to turn off the alarm?

I just received mine and connected it to my linux pc laptop for the first time. It makes constant dial up modem noise non-stop. I’m assuming I have to connect this way to run the commands required to set this thing up?

Had anyone found a way around this yet? Based on what @Steesh said, using a power adapter doesn’t stop the dial up modem noise when the USB is plugged into a linux laptop.

I suspect the laptop is sending ‘a’ over serial (a/A is start/stop alarm, a yet undocumented feature).

Could you test this?
I think the commands should be:

sudo echo -ne 'a' > /dev/ttyACM0
sudo echo -ne 'A' > /dev/ttyACM0

We can fix this by making our commands longer, so it is a lot more unlikely that a laptop would send them accidentally.

Tried sudo echo -ne ‘a’ > /dev/ttyACM0 …and I get:
bash: /dev/ttyACM0: Permission denied

I added myself to the “dialout” group thinking that might work but that didn’t help. (sudo gpasswd --add ${USER} dialout)

Any ideas?

Can you check that the port is correct?

run from the script dir to detect which port the device is on.

It worked! No more horrible dial up noise!
I was plugged into ttyACM3: sudo echo -ne ‘a’ > /dev/ttyACM3
I downloaded from and it gave me the answer.

Is there a good place to run this command on server startup? I’m guessing every time I reboot or unplug it’s going to go off again?

Insert here (line 461), just before the while:

Insert this:


I have not tested this.