Spark service not starting

My spark service worked perfectly until recently when I updated my pi software. I removed the service and tried to re-install, but it won’t work. Also tried to force an install manually by using the spark id and ip address, but no success. I have also run a brewblox update.

The termbin link is and I attach the .json log file as well.brewblox-logs.json (2 Bytes)

In your terminal, what errors do you get when you run brewblox-ctl up?

Hi Bob. Here goes:
Traceback (most recent call last):
File “/home/pi/.local/bin/docker-compose”, line 6, in
from compose.cli.main import main
File “/home/pi/.local/lib/python3.7/site-packages/compose/cli/”, line 46, in
from .command import get_config_from_options
File “/home/pi/.local/lib/python3.7/site-packages/compose/cli/”, line 19, in
from .docker_client import get_client
File “/home/pi/.local/lib/python3.7/site-packages/compose/cli/”, line 10, in
from docker import Context
ImportError: cannot import name ‘Context’ from ‘docker’ (/usr/local/lib/python3.7/dist-packages/docker/
Command ‘docker-compose up -d --remove-orphans’ returned non-zero exit status 1.

It looks like there’s a kink in the docker-compose application used to start brewblox.
To update, run

pip3 install --user -U docker-compose
pip3 freeze

Afterwards, run brewblox-ctl up again to see whether it took.

No luck. I just got a bunch of “Requirement already satisfied, skipping upgrade” replies.

Do you by any chance still have the output? It’s possible to force installation of packages, but depending on your environment, that may also break things.

I do - see attached Pi dump.txt (7.0 KB)

Thanks. Looks like the docker package indeed is a few versions behind. I guess docker-compose should fix its minimum requirements.

To update the docker package:

pip3 install --user -U docker

It appears the latest version of docker is 4.2.1 (you have 3.7.3).

Sorted! Thanks Bob. By the way, I’d like to set my pi up so it boots directly into chromium (fullscreen) and loads the ui. Ho do I do that? seems to be the recommended approach, but I don’t have a Pi with a desktop install on hand to test.

Thanks Bob. I entered the following line in autostart:
@chromium-browser --start-fullscreen --ignore-certificate-errors --disable-restore-session-state https://localhost/ui/
and it works like a charm.