Spark Setup Issue

I’d like to say there is a lot of potential with your product stack. Unfortunately, I am having problems detecting the GPIO module and temperature sensors. I have a Spark 4 that I purchased a month ago and 3 temperature sensors (silicon) I bought along with it. I also have an additional GPIO module. Below are the vitals. No matter how many times I flash, delete and clear blocks or run a discovery, the unit will not detect any of the temperature sensors. I have tested each sensor one-by-one with no luck.

Interestingly, I was able to detect the GPIO modules and temperature sensor when I first got the Spark but not since. Even the first setup it took a couple of hours of reboots, flash and discovery to detect the temperature sensors. I am not sure what to do next. Any help is greatly appreciated. Thanks. Paul

Could you please run brewblox-ctl log to share system logs?
If you plug in the sensors one by one, are they discovered? If you have multiple sensors plugged into the same bus, and one of them is faulty, none of them can be read.

Regarding the screenshot: a fix for the IP on Spark 4s has been implemented, and will be part of the next release.

Thanks Bob!

The logs are uploaded:

No. I cannot get any sensors to detect if I plug them in one at a time. I also tried them on different RJ11 ports. Also, I am using a RPI 4 approved USB power adapter.

Good to know on the IP fix.

It looks like the Spark itself is closing connections at times. This may be due to firmware errors, connection hiccups, or you restarting the Spark.

Do you hear unprompted Spark reboot beeps?

Could you please connect the Spark over USB, and run brewblox-ctl coredump? This fetches the last crash report (if any).

Network-side, IPv6 has historically had some very unfortunate interactions with Docker. If you have you specific reason to use it, you can try disabling it altogether on the Pi:

echo 'net.ipv6.conf.all.disable_ipv6 = 1' | sudo tee /etc/sysctl.d/90-disable-ipv6.conf
sudo sysctl -p /etc/sysctl.d/90-disable-ipv6.conf
sudo reboot

Performed a coredump over USB and ran the script on the rPI to disable IPv6. Same issue. Does not detect any of the sensors.

The coredump is empty, indicating that the controller did not crash.
In combination, we can effectively rule out software causes.

If you open a ticket in the webshop, we can arrange replacement hardware.

Ok. I will send an RMA request. I did modify the enclosure. It would keep inadvertently opening on me. Thanks for your help!

Hello there,

since i manage to move my spark for a better place, and so change temperature sensor cable, i’m not able to have spark working and finding any sensor or GPIO module anymore

Please help me

A single faulty sensor will prevent other OneWire sensors being read. To find the broken sensor:

  • unplug everything
  • one at a time, plug in a sensor, and refresh the UI to discover.

I’ve tried, even by deconnecting the GPIO, clearing every module, but even the GPIO is not discoverable

Could you please only plug in the GPIO, refresh the UI, and then run brewblox-ctl log?

Also, could you please take the Spark and the module out of their enclosures, and take close-up photos?

brewblox.log (412.8 KB)

It looks like you’re still running the previous release. This had a bug where disconnected OneWire devices could slow down the system to the point where it became unresponsive.

If this is the case, the problem should be resolved if you run brewblox-ctl update and brewblox-ctl flash.

update run well, but flash goes an error

pi@raspberrypi:~/brewblox $ brewblox-ctl flash
INFO Flashing Spark 4…
edge: Pulling from brewblox/brewblox-devcon-spark
Digest: sha256:ddf9deaecd36bfb88ecc0504eb609429dc21acdd36e48b072da22781ae252566
Status: Image is up to date for brewblox/brewblox-devcon-spark:edge
Flashing ESP32… v4.3
Found 1 serial ports
Serial port /dev/ttyAMA0
/dev/ttyAMA0 failed to connect: [Errno 25] Inappropriate ioctl for device

A fatal error occurred: Could not connect to an Espressif device on any of the 1 available serial ports.
Command ‘docker run -it --rm --privileged -v /dev:/dev -w /app/firmware --entrypoint bash --pull always brewblox/brewblox-devcon-spark:edge flash’ returned non-zero exit status 2.

And on the ui, if i try to update firmware i’ve got :slight_smile:

Update failed: Request failed with status code 424

Please retry.
If the retry fails, run brewblox-ctl flash

i’ve eanbled serial port on rpi, reboot, and brewblox-ctl flash works

but, there is no discovery of GPIO module
brewblox (1).log (232.3 KB)

Can you explain what kind of changes you made to the cable?
Did the hardware work before?
I don’t see anything wrong in the photos.

Just unpluged the RJ11 sensor, and when i plug them back, there was no more data, and impossible to find then back.

That was working realy fine before