Spark Setup Issue

I’d like to say there is a lot of potential with your product stack. Unfortunately, I am having problems detecting the GPIO module and temperature sensors. I have a Spark 4 that I purchased a month ago and 3 temperature sensors (silicon) I bought along with it. I also have an additional GPIO module. Below are the vitals. No matter how many times I flash, delete and clear blocks or run a discovery, the unit will not detect any of the temperature sensors. I have tested each sensor one-by-one with no luck.

Interestingly, I was able to detect the GPIO modules and temperature sensor when I first got the Spark but not since. Even the first setup it took a couple of hours of reboots, flash and discovery to detect the temperature sensors. I am not sure what to do next. Any help is greatly appreciated. Thanks. Paul

Could you please run brewblox-ctl log to share system logs?
If you plug in the sensors one by one, are they discovered? If you have multiple sensors plugged into the same bus, and one of them is faulty, none of them can be read.

Regarding the screenshot: a fix for the 0.0.0.0 IP on Spark 4s has been implemented, and will be part of the next release.

Thanks Bob!

The logs are uploaded: https://termbin.com/9oc6

No. I cannot get any sensors to detect if I plug them in one at a time. I also tried them on different RJ11 ports. Also, I am using a RPI 4 approved USB power adapter.

Good to know on the IP fix.

It looks like the Spark itself is closing connections at times. This may be due to firmware errors, connection hiccups, or you restarting the Spark.

Do you hear unprompted Spark reboot beeps?

Could you please connect the Spark over USB, and run brewblox-ctl coredump? This fetches the last crash report (if any).

Network-side, IPv6 has historically had some very unfortunate interactions with Docker. If you have you specific reason to use it, you can try disabling it altogether on the Pi:

echo 'net.ipv6.conf.all.disable_ipv6 = 1' | sudo tee /etc/sysctl.d/90-disable-ipv6.conf
sudo sysctl -p /etc/sysctl.d/90-disable-ipv6.conf
sudo reboot

Performed a coredump over USB and ran the script on the rPI to disable IPv6. Same issue. Does not detect any of the sensors.

https://termbin.com/rbd6

The coredump is empty, indicating that the controller did not crash.
In combination, we can effectively rule out software causes.

If you open a ticket in the webshop, we can arrange replacement hardware.

Ok. I will send an RMA request. I did modify the enclosure. It would keep inadvertently opening on me. Thanks for your help!