Spark V2 beeping repeatedly, now appears dead

I was outside minding my own business when my Spark V2 started beeping repeatedly about once a second. The screen was also flashing as if the Spark was rebooting at that frequency. I immediately unplugged the USB cable (from the Pi side). When I reconnected the USB power cable I got no response from the Spark; no beeps and the screen stayed blank. I tried a different USB cable on a laptop and still nothing. Last, I tried the 12V power supply from my Spark V3 and still nothing. The status LED is also blank, though there is a green LED inside the case that lights, which is the only sign that anything happens when power is applied.

This Spark has been running for years from the same RPi 3 and USB cable. For almost all that time it was running BrewPi software. However, on 22 Mar 2020, I upgraded to BrewBlox. The upgrade went smoothly as did setting up the Fermentation fridge profile. The Spark ran fine till today. I’m not sure if the upgrade is related (doesn’t seem like it would be), but sharing just in case.

Help!? @Elco ?

Some electrical part may have burned out.
Could you please open the casing, and take some pictures of both sides of the board?

Thanks @Bob_Steers
Took many pictures since the flash reflection always blinds a spot.

I don’t see anything that looks obviously wrong.
If you power the photon via USB, does the LED light up? And what colour and pattern?

Nothing happens when I connect USB power to the photon. No lights or sounds.

Sound is on the main board. So that makes sense.
Does holding the setup button so anything? And holding it while resetting?

Factory reset is 10s hold after reset.

Nothing. Tried press & release each in turn, press & release both, press & hold each individually, press & hold both.

Trying a new photon on the board sounds like it is worth a shot. If you are lucky, it’s just the photon that is broken.

If I purchase a new Photon, where can I find instructions to get it ready for BrewBlox?

Anything I can do to test the BrewPi Spark board?
When I connect 12V power (screen and photon not attached), green LEDs light solid at 5V and 12V.

Also … (prolly of no interest at this point, but)
Just noticed that on the Photon, when I connect USB power, there is an LED by the VIN pin that barely lights red then goes away, about 0.5 -1 sec.
The Photon board gets hot (to the touch) under the USB connector. Nothing else on the board gets hot (to the touch).

Just installed the new photon.
brewblox-ctl bootloader … failed (or did nothing).
brewblox-ctl flash … succeeded (even after a message that /dev/ttyACM0 wasn’t available)
brewblox-ctl wifi … completed successfully.
brewblox-ctl add-spark … completed successfully.

Everything looks fine in the Web UI !

Minor note:
Not sure why I got the error Error: No such file or directory, cannot open /dev/ttyACM0 for every command that accessed the Spark over USB (and then succeeded anyway).
I also updated code on my Spark 3 over USB and it didn’t display that message.

Thanks for all your help and responses.

1 Like

Happy to hear it works!

The various flash commands attempt to prepare the controller first. If the controller already is prepared, that causes an error, that we promptly ignore.

The Spark 2 is running the Fermentation Fridge again. Everything looks good in the Web UI but the Spark screen is blank. It was blank the whole time I set it up and I hoped that it was because there was nothing to draw. The display widget in the UI is set to display the heat and the cool pid widgets.

Any troubleshooting suggestions?

You can check if the ribbon connector for the display is properly seated. Those can be a bit tricky.

This V2 board doesn’t have a ribbon cable. It could still be bad contact, or the display is damaged.

Is everything else working? I can look through my old parts for a V2 display.

Just wanted to follow up here … and realized @Elco asked a question (sorry for the lack of response).

Yes, everything else is working fine!

Regarding the Spark V2 display, I still have the original (had gotten a replacement early on for a bad portion of the original screen). I re-installed the original screen and it shows the same, screen is lit and is all white (it lights up the garage at night). I assume this means it is not a hardware issue with the screen itself.
(EDIT - the original post wasn’t clear in that “blank screen” meant it had power and lit up all white, just nothing drawn there. I expect the display to show the two blocks for the standard fermentation fridge setup, “cool pid” and “heat pid”)

Any thoughts regarding troubleshooting are appreciated.

Otherwise, I can deal with the current state. I know this is an older product and with everything else working, it’s doing the most important part of it’s job. I’m glad that BrewBlox works on it and I can continue using it!

Two broken displays, or bad contacts at the terminals. The display IC is on the red board, so the photon is directly driving it. Check the SPI pins and their mating connector. Those are the pins labeled MISO, MOSI and CS in the middle. Not group of 4, those are for the sd card slot.

I flashed the latest firmware on the sparkV2 today and after rebooting, the screen now has 6 gray boxes. Still not showing the block content “cooling PID” and “heating PID”, but makes me think that physical connections are all okay.

Any reason to still check those pin contacts?

Sounds like it is working! Just add the blocks in the display settings widget.

I have yet to find a pattern here.

  1. From before, the screen was blank (powered and lit white) after flashing with latest spark firmware.
  2. The RPi3B+ lost network, so I rebuilt it (re-flashed SD card, setup brewblox from scratch again.)
  3. Flashed and discovered the Spark via USB.
  4. Removed USB power and connected 12V power. Then the screen changed from white to 6 gray boxes (with other details in the corners.)
  5. Made changes to the spark display in the web UI and checked nothing changed on the spark screen.
  6. Power cycled the Spark and now back to a white screen again.
  7. Made additional changes to the spark display in the web UI but spark screen stayed white.

My next step is to swap screens again (put in the new one) as I see the bad artifacts on this (original) screen. At that time I’ll inspect the pin connections mentioned above just for completeness.

Happy to try any other suggestions.

It is certainly a hardware issue. It is not related to the firmware on the Spark or anything installed on the pi.