Spark V2 with white screen


#21

Where do I begin? I tried updating my spark via the instructions. The update went sideways somewhere, and now the screen is white on the spark. The webpage loads, but there isn’t the little box in the top left corner saying what the temps are. The script will also not run.


#22

Can anyone please help me get my brewpi back into working order?? I just want to remove it all and start fresh.


#23

I followed the instructions here to install BrewPi from scratch and it worked for me:

https://wiki.brewpi.com/getting-started/raspberry-pi-docker-install

Are there any specific errors you get running any of the steps? As far as I can tell your issue is only at the point at which you try and update the BrewPi Spark to the latest firmware?


#24

When I try to start the brewpi container this comes up.


#25

I am in the process of reformatting the SD card from my Raspberry Pi, and I will try to reinstall everything brand new and see how far I get.


#26

Did you execute the following part of the instructions:

Finally click on ‘endpoints’ in the left menu. Click on the only endpoint which is called ‘primary’ or ‘local’. In the public IP field, enter raspberrypi.local or the IP address of the pi. If you omit this step, clicking on exposed ports of a container will link to 0.0.0.0:80 instead of raspberrypi.local:80, which will not work.

You should execute this in the portainer console.

success!

DouBrew


#27

I thought I did. I’m starting from fresh, so I’ll hopefully be up and running soon.
Its just so frustrating because I did alot of different things people and forums told me to do, and I think I messed up alot of things along the way.


#28

So I have reinstalled everything and am stuck with brewpi not working.
The containers have been installed properly and are running as should be.

The sparks screen is still white.
When I plug it in, this is the sequence of lights I get on the bottom side…
White, 3 fast reds, 3 slow reds, 3 fast reds, 1 red, 3 fast reds, 3 slow reds, 3 fast reds, 1 red, and then it restarts the sequence.
Is this the SOS sequence?

When I try to update by re-creating the docket via the wiki page,
I type ssh pirate@192.168.1.100 and I recieve: ssh: connect to host 192.168.1.100 port 22: no route to host


#29

If the user name is pirate, you are still using hypriot. You should use rapbian instead.

Try the following:

  • hold the set up button for 10 seconds until it flashes white. This is a factory reset that also wipes BrewPi firmware.
  • next set up WiFi with the app.
  • then put it in Dfu mode and run flashDfu.py