Spark V2 with white screen


#1

I tried updating with the updater.py string and it went through its paces but ended up with a white screen on the unit.
I tried the DFU way and it wont work.
Please HELP! Btw im not very saavy when it comes to all the coding or whatnot, just please bare with me…


#2

I had this issue recently after updating and fixed it by connecting the particle to wifi. You need to download the particle app (it’s called “Particle” on Android) and just follow the instructions. Once connected it should boot up as normal.


#3

This is because newer versions of the firmware require a new boot loader from Particle. It will sit there waiting if it’s not connected to the Particle cloud


#4

I downloaded it on my phone, but dont understand what to do next… It says to put it in setup mode and the light will flash blue…
It flashes red all the time unless I restart it while holding in the setup button. Which makes the light flash yellow.
Nothing I do works.
I might try uninstalling it and redoing everything


#5

…and figuring out how to uninstall it is mind boggling. Im so lost and just want this to work. Ive got a brew planned soon and I’ll be pretty upset if I can’t brew because my brewpi is all jacked up.
Im trying to follow all the brewpi related notes and forums, but NOTHING is working.


#6

Here’s what the Photon colors mean:

https://docs.particle.io/reference/led/photon/

Once it’s in DFU mode (entered by holding down the setup button while powering) and it flashes yellow you should be able to set it up using the Particle phone app. Just follow the instructions the app says.


#7

This might help too:

https://docs.particle.io/guide/getting-started/start/photon/


#8

Do I set up a photon? If so, it cant find any.
Do I set up an electron? Didnt know if I should so I didnt sign up.
Do I set up a core? If so, the spark app I was made to install sits there trying to connect to my Wi-Fi, but never finishes or something.


#9

How do I simply wipe everything out pertaining to brewpi and restarting??? The led is flashing Red unless I do the yellow led thing. I cant get the blue led to come on at all. The screen is still white, the docker stuff almost worked, but is having errors now at the end. Im starting to lose hope with this thing, and it makes me a little angry. All this because I tried updating it the way the wiki page said to… Why put the steps out there for someone to complete, thus screwing up the whole system?! Ugh…


#10

So where did you get with using the phone app? If you have a Spark V2 I think that means you have a “core”. I have a V2 as well so I can check when I get home.


#11

The proton didnt find anything, I dont think I have the electron, and the core froze up when I tried accessing my wifi


#12

Actually V2 uses a Photon. V1 used a Core (previously called a Spark). Once you select Photon the instructions the app gives you is pretty straight forward. If you still can’t do it you’ll have to wait for @Elco to get back from holiday.


#13

The Spark app freezes up when I try to access the Wi-Fi.


#14

Anyone know when Elco will return?


#15

Perhaps I can try to help…

Just to be sure: you followed this guide? https://wiki.brewpi.com/getting-started/updating and in particular “Updating the BrewPi Spark firmware with DFU” with docker? So at the end of the instructions you basically updated the Brewpi firmware succesfully (or did you got errors in between?), but afterwards got a white screen?

(I got the same, but could solve it by starting the Particle app on my phone and reconnecting to the Particle cloud by entering my wifi credentials via the app. It automagically updated the Pothon bootloader then)

If you can conform all of this, I believe the DFU way worked the way it should. Hence I agree with the conclusion from @Hokie_brewer and @Dan that the bootloader of your Photon is outdated.

Can you please closely check how the red light is blinking when you enter the Particle app? The Particle documentation (https://docs.particle.io/reference/led/photon/#red-blink-basic-errors and https://docs.particle.io/reference/led/photon/#red-flash-sos) basically provides you two options:

  1. Red blink basic error: something is wrong connection tot the internet -> perhaps retry in a different network? recheck your network.
  2. Red Flash SOS: the firmware is crashing. -> possibly the firmware updating did not go the way it should. please repeat the complete update guide provided by Elco. Check every step.

Good luck. Hopefully it worked.


#16

Im not sure how it went with the updating…
I first tried to update with the first way on that page, and thats when I got the white screen.
I tried updating with the DFU way, but there was some sort of error or something, i cant really remember. Ive had lots of errors throughout this process, I cant remember which was what.
I do believe the led sequence is the SOS one. Ill have to confirm once I return home.
I also tried installing the docker thing, as I installed 2 years ago via the github way i believe. But the docker way didnt work 100% either.

Its all massivly confusing for me at the moment… Wish I could just uninstall it all, then reinstall it all from scratch.


#17

I think now the best way is to start all over by setting up Brewpi in combination with Docker as described on wiki.brewpi.com (Docker installs Oracle Virtualbox as well on Windows. Easiest way is to install and use Docker on Windows is to use Windows 10).

Then follow the firmware update guide (DFU) Windows/Docker guide (by adding DFU to the default virtual image settings).

It takes some time to follow all the steps and you have to read very carefully.


#18

I tried reinstalling it all with the docker, but it doesnt work.
The script doesnt run in brewpi, and the container thing doesnt work.


#19

Anyone know when Elco will be back?


#20

It would be easier for us to help if you describe in detail what and where things go wrong. Without any detailed feedback even Elco can’t help you I guess.