Spark v3 drops wifi


#21

Hi @adempewolff,

If you are looking for a temporary workaround, at Elco’s suggestion I set my WiFi access point to use 20 MHz channels rather than 40 MHz. The brewpi spark has not disconnected from WiFi since.

If you are able to deal with the performance impact, at least until this issue is addressed in a software update for the spark, I would highly recommend adjusting the channel width on your WiFi router or access point.

Note: 40 MHz channels have higher data rates with 802.11n or 802.11ac, but are more susceptible to interference than 20 MHz channels.

@Elco, thanks for the tip!


#22

Awesome, thanks for the feedback. I’m looking at a software fix this week.

The reason for the 40Mhz/20Mhz setting working:
A 40Mhz bandwidth is actually just 2 20Mhz channels combined. The Photon can only use 1 20Mhz band and when 2 are available it can switch between the two. The channel switch is not handled correctly and cause a loss of connectivity. When only 1 20Mhz channel is available, there is no switching.

So the best workaround so far is to set your router to a fixed channel instead of auto and to set it to 20Mhz bandwidth.


#23

I’m running into this one as well. Whenever there’s a fix ready to test will we see something here or should I just monitor GitHub?


#24

Just got a new Spark v3 and ran right into this. Also interested in any updates.


#25

Been running the new firmware for a couple of weeks and have not seen this issue reoccur. Thanks for the update, and looking forward to the all-new stuff in a few months so I can control multiple fermentations :grinning: