Spark will not connect to other SSID

Currently setting up a fermentation fridge.
Having soldered everything, it’s time to move the configured spark to the shed with a different SSID.
Setting the wifi configuration results in a green flash message stating success, when unplugging and plugging in the spark in the shed, it will not connect.
Even when moving the router into the house, when the spark is connected via usb to the brewblox server, it will not connect to the ‘shed’-SSID.
Connecting to the ‘house’-SSID is a matter of seconds. When booted in the shed, the light flashes green with a sparse white-flash in between, to no end.
Confirming it is connected to the ‘house’-SSID is easy enough as this has a separate IP range.

Rebooting the brewblox server. service, spark, etc in any different order has no effect.

Anyone a suggestion how to approach this?

termbin url:

It may be that the house wifi is still detected.

To erase the stored wifi networks on your spark, hold the SETUP button until the LED blinks dark blue, then continue to hold it down for about ten seconds longer, until the LED blinks blue rapidly, then release.
Then set the SSID/password for the shed, and try again.

Also: what is the frequency of your shed’s wifi? I believe the spark only supports 2.4GHz, but I’d have to confirm to be sure.

Aah… I am trying to connect it to 5GHz…
That should be easy enough to figure out.

Ok, took a while, but it worked like a charm…
Connecting to a 2.4GHz network didn’t work (at that point), I used the SETUP procedure as described by Bob, and configured the new wifi settings.
All sensors were recognized and renamed. Added the dashboard for the fermentation fridge!

All in all: a good day.
Thanks to man of the hour Bob! :smiley:

1 Like