Spark won't power on

So I have had the Brewpi Spark setup with a Raspberry for about a year. All programmed and working multiple times through various tests. I hooked it up again yesterday and powered everything on, it was working fine sending temperature data to the pi for web access…

I moved the hardware to my brew room and started brewing. I am in the middle of brew and cannot get the Spark to turn on. No screen, no beep. I have the raspberry power it through usb which has always worked except now. The Raspberry is fully functional and powered on. I tried different USB’s on the Raspberry as well as different USB cords themselves.I even tried to power it on for another source through USB and it did not turn on.

Any suggestions?

If it is fried do I have any options?

Can you try with a 12V adapter? The USB port could be damaged.

Hey, I found a 12v I was using for a solidrun iP4 mini computer. It booted the spark. Got beep and shows main screen.

Is the USB part replaceable for future use? Since the USB doesn’t work does this mean I need a new Photon?. I tried to do the setup via the particle app to get connected to wifi and got a slowly blinking green light on it.

But then your wifi instructions say the address needs to be entered and can be found on the front panel of the Spark (controller right). Mine doesn’t display. Could this be that it really didn’t connect or that the photon firmware is out of date…?

Sorry, I know a lot of questions but just trying to see since the USB is wacked if I could connect via wifi to still control.

Sorry, I didn’t even realize this could be powered by 12v cord rather than USB.

Aha. That clarifies the situation.

I think that the photon is still okay, but the USB connector on the photon is broken. The USB connector cannot really be replaced separately, the entire photon module should be swapped (available for 19 USD here). It could be that it is a combo of USB connector and cable, but I must say the USB connector on the photon is pretty weak and a jank on the cable can already break it. That’s one of the reasons we switched to a separate USB connector on the new model.

Only release 0.5.0 has WiFi functionality, but it was only released as beta so far and it will not be possible to update to it without USB I think.

Ok. I was never sure if the 0.50 version was the pi or photon software. I’ll order a photon. Two things:

  1. Order the photon with or without headers?
  2. Is there any instructions somewhere on replacing the photon including any software needs?

Appreciate it.

With headers.

Open the case by removing the four screws, then insert a small screw driver, darts arrow or similar into the notches in between the bottom and side to lift unhook the bottom part. Replacing the photon is just taking out the old and putting in the new part.

To flash it with the BrewPi firmware, put it in DFU mode:

  • hold the mode button
  • press reset
  • release reset
  • keep holding the mode button until the LED on the photon flashes yellow

Then run these command to flash the firmware:

cd /home/brewpi/utils
sudo python

Awesome. Thanks for your response. Will order photon tonight.

Elco, I rec’d Photon and updated firmware as well as upgraded BrewPi firware on pi to latest… I am trying to start a new brew configured for a glycol pump setup - Beer Constant. Below is some of the problems I am facing…

#1. In the Top Black box it says “Script starting up”. Not sure why this hasn’t finished starting up…may be related to #2
#2. In the logs I keep getting a “Controller debug message: WARNING 1: Invalid command received by Arduino: 1”
#3. The “State” never changes to “Cooling” or “Heating”. My temp is around 67.2 and target is 68. Should be on Heat…

Not sure how to troubleshoot this - can you help? (BTW, I do have a Brewometer integration.)

Appreciate any advice!

It looks like you have a customized script and web interface to include the gravity. Did you do this on a custom branch?

Can you try the non-modified versions of the script and web interface?

in both repositories (/home/brewpi and /var/www/html) run these commands:

If you don’t have a custom branch, make one that includes your modifications:
git branch gravity' Check that you have no uncommitted changes:git status`

If you do have uncommitted changes, commit them so you won’t loose them:
git add -A
git commit -m "modifications for gravity"

Check out the master branch
git checkout master

Reset the master branch to what it originally is from the brewpi remote
git reset --hard origin/master

Do this for both repositories and let me know if you still have problems. Also update your firmware to the latest release.

So now I cannot start a new brew. Maybe it’s something easy and i’m just an idiot but I’ve clicked on enough stuff and even tried a new install. Suggestions?

Ok, not very familiar with git or Linux so I decided since it was such an old build I would start a little fresher…

I went back and update the rpi firmware and all the software using you installation guide. I started after the network was setup with SSH. Here are the commands I ran…the first 3 took a long while and updated a boat-load of software. I did not see any errors except there were 17 files that did not get updated or removed…

sudo apt-get update
sudo apt-get upgrade
sudo rpi-update
sudo apt-get install git
git clone ~/brewpi-tools
sudo ~/brewpi-tools/

Everything looked great at first. Have the new web console with the temps and state in black at top.

Here is where the problem is: I can stop the “Sample Date” beer and start another by clicking on the white hyperlink next to “Fermenting:”. What doesn’t happen on the webconsole is the new beer is never started. I checked the logs and here is what shows:
Jul 20 2017 07:46:05 Notification: Script started for beer 'My First BrewPi Run’
Jul 20 2017 07:46:05 Connecting to controller…
Jul 20 2017 07:46:05 Opening serial port
Jul 20 2017 07:46:05 Checking software version on controller…
Jul 20 2017 07:46:05 Found BrewPi v0.5.1 build 0.5.1-0-ga1d812ffa, running on a Particle Photon with a V2 shield on port /dev/ttyACM0

Jul 20 2017 07:46:56 Stopped data logging, as requested in web interface. BrewPi will continue to control temperatures, but will not log any data.
Jul 20 2017 07:46:56 User config file /home/brewpi/settings/config.cfg does not exist yet, creating it…
Jul 20 2017 07:48:40 Notification: Restarted logging for beer ‘Test’.

Not sure why the config.cfg file wasn’t created unless it doesn’t until your first beer is started.

Here are the contents of the install:
pi@raspberrypi:~ $ sudo ~/brewpi-tools/

Checking for Internet connection…

Checking whether this script is up to date…

/home/pi/brewpi-tools is up-to-date.

***** Installing/updating required packages… *****

Reading package lists…
Building dependency tree…
Reading state information…
apache2 is already the newest version.
build-essential is already the newest version.
git-core is already the newest version.
libapache2-mod-php5 is already the newest version.
pastebinit is already the newest version.
php5 is already the newest version.
php5-cgi is already the newest version.
php5-cli is already the newest version.
php5-common is already the newest version.
python-dev is already the newest version.
python-pip is already the newest version.
The following packages were automatically installed and are no longer required:
libasn1-8-heimdal libgssapi3-heimdal libhcrypto4-heimdal
libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal
libkrb5-26-heimdal libroken18-heimdal libwind0-heimdal libxfce4ui-1-0
Use ‘apt-get autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 17 not upgraded.

***** Installing/updating required python packages via pip… *****

Requirement already up-to-date: pyserial in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: psutil in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: simplejson in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: configobj in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: gitpython in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: six in /usr/local/lib/python2.7/dist-packages (from configobj)
Cleaning up…

***** Done processing BrewPi dependencies *****

Disk usage is 16%, free disk space is 25G. Enough to install BrewPi

To accept the default answer, just press Enter.
The default is capitalized in a Yes/No question: [Y/n]
or shown between brackets for other questions: [default]
The time is currently set to Thu 20 Jul 07:44:02 EDT 2017. Is this correct? [Y/n]Y

*** This script will first ask you where to install the brewpi python scripts and the web interface
Hitting ‘enter’ will accept the default option in [brackets] (recommended).

Any data in the following location will be ERASED during install!
Where would you like to install BrewPi? [/home/brewpi]:
Installing script in /home/brewpi
Install directory is NOT empty, are you SURE you want to use this path? [y/N] y
Ok, we warned you!
Searching for default web install location…
Found /var/www

Any data in the following location will be ERASED during install!
Where would you like to copy the BrewPi web files to? [/var/www]:
Installing web interface in /var/www
Web directory is NOT empty, are you SURE you want to use this path? [y/N] y
Ok, we warned you!

***** Creating and configuring user accounts… *****
User ‘brewpi’ already exists, skipping…

***** Checking install directories *****
/home/brewpi already exists
Script install directory is NOT empty, backing up to this users home dir and then deleting contents…
/var/www already exists
Web directory is NOT empty, backing up to this users home dir and then deleting contents…

***** Downloading most recent BrewPi codebase… *****
Cloning into ‘/home/brewpi’…
Cloning into ‘/var/www’…

***** Running from the script repo. *****

***** Fixing file permissions for /var/www *****

***** Fixing file permissions for /home/brewpi *****

***** Running from the script repo. *****

***** Updating cron for the brewpi user… *****

no crontab for brewpi
Checking entry for brewpi …
Done checking entry brewpi …
Checking entry for wifichecker …
Done checking entry wifichecker …
Restarting cron
Restarting cron (via systemctl): cron.service.
Done installing BrewPi!

Review the log above for any errors, otherwise, your initial environment install is complete!

It is normal that the config file is created on first write.

Did you refresh the page with ctrl-F5?

As an alternative approach, I’m working on a docker based install and I think it is ready for use.
You could give it a test drive for an easier install process: