Spark3 USB to PC connection not recognized in Brewpi


#1

Hello everybody! I’m using a PC and USB and I can’t get Brewpi to recognize my Spark3. In Brewpi the script is running but I have a message Error: Connection to BrewPi Spark interrupted.

  • I’ve enabled USB1.1 in VirtualBox.
  • I’ve added the privileged flag when starting the container in DockerToolbox. This is what I put:
    docker run -d --name brewpi -p 80:80 --privileged -v ~/brewpi-data:/data -v /etc/timezone:/etc/timezone -v /etc/localtime:/etc/localtime --restart always brewpi/brewpi-ubuntu
  • My Spark powers on, beeps, and takes me to the Hardware Test Screen when connected to the PC. There is a pulsing blue light.
  • I can find the Spark in my PC under “Printers and Devices”, listed as P1 in category “unspecified”.
  • I have tried 3 separate USB cables, one of them brand new.

Thanks in advance to anyone who might have some insight into this issue.
-Steven


#2

I abandoned trying to connect the spark with usb and attempted wifi. I used the Particle App to setup my photon wifi. I modified the config.cfg file to use TCP socket using the IP displayed on the Spark hardware test screen. Brewpi still says Error: Connection to BrewPi Spark interrupted.

I have done this from the beginning, following all the instructions, twice. Any ideas?


#3

It sounds like the PC doesn’t have the right driver. You can try installing particle-cli on the windows PC and see if it is recognized then.
Also note that a docker container gets its devices when it starts and cannot have access to newly plugged in devices.

You don’t need to modify the config file, there is a field in the Web UI under maintenance to enter the IP address of the Spark.


#4

Elco,

I finally got around to trying your suggestion and it worked. Thanks for the support. Time to brew some beer!