SSR supposed to switch fan on, but doesn't

my setup is pretty much complete, the brewpi controls the fridge compressor (cooler) and a tube heater, works like a charm. The fridge has a built in fan (it’s an old gastro-style pro fridge) which i hooked up to a third SSR (the standard 10A one). However, even though the software says active, the fan doesn’t power up and the SSR’s LED is dark. If I connect the two output screws of the SSR with a small piece of cable, the fans starts turning. I have no knowledge about the power consumption of the fan, but it does run on 220 V, thats for sure. So, is the current too low for the SSR to actually switch? What different SSR should I use instead? Are there 1A versions available too?


Hey @AlexZ,
I’d check your wiring and voltages going to the SSR . If the relay is not lighting up, you aren’t getting power to the relay, thus the fan not coming on.
Also, double check the SSR you have, verify the input side is for 3-5v dc. The 10A part is fine.

Check by toggling inverted/not inverted in device manager to toggle the relay from the web interface.
This should toggle the LED on the BrewPi board and the LED on the SSR. If the LED on the SSR does not toggle, your problem is on the control side.

Guys, thanks for your great and fast support!
A weird thing occured. Yesterday I turned everything (fridge, brewpi) off and posted my question afterwards. Today I turned everything on and now it works despite not having touched or changed anything except the power buttons… I love those problems that solve themselves. Anyway, I have a nice fridge now with a fan that’s switched on both during cooling and heating. Thanks again, this is solved!