SSR's not switching

Hi! So i’ve been reviving my brewpi as it’s getting rather warm here.

I’m having issues with the SSR’s switching. Am i right in thinking there’s also a LED on the shield that should light up when the thing starts to cool or heat? Well that does not light up either. Tried two different SSR’s, definitely were working last time i used them. Cannot get the things to go tho!

This is the settings you can see it is active.

The settings look correct. The Arduino says it is cooiling. The LED on the shield should be ON.
The LED on the SSR as well.

Are you running an Arduino Uno with RevA shield?

Yes i am. Arduino SA Uno R3 (CDC ACM). i’ve had it for a while now without really managing to use it properly!

i get nothing with the multimeter on the cool relay port. i actually get some action on the heat port. the led lights up and i get 5v on the multimeter. should have checked that earlier but yeah, looks like my cool is cactus! :frowning:

I’d buy a new (programmed) chip for your UNO. Did you use mechanical relays at some point?

ooh i actually have another arduino i think! will try that.

I have not used any other relay at all no.

Ok brand new arduino. Still no action on the cooling. Must be the shield? Mega bummer.

Hmmm. Did you get a soldered shield or kit?
Can you measure the voltage on Arduino pin 6?
Can you make a high res photo of the top and bottom of the shield?

I’d like to resolve this with you, but it might be easier to have direct chat, via the store chat or on IRC (

Hey Elco, this was a soldered kit from you yep. Not 100% sure if i’m reading the voltage correctly on the arduino pins. I can see 4.95v if i stick one probe on ground and the other on pin 6.

Here’s a couple of pics of the shield.

Ah, you got a rev A shield. I thought you received yours recently.

With the actuator set to inverted, the Arduino Pin should read low when cooling is active, 5V when idle. You can just measure in the hole next to the pin.

You can flip the invert setting to toggle it for testing.

oops just realised i posted two top view pics! was in a hurry this morning! fixed that.

Ok so, when i’m measuring the the voltage on pin 6 with the shield attached and it is waiting to cool and the actuator is set to inverted the voltage is nothing. as soon as it flicks over to cooling the voltage jumps to 5v. the led on the shield does not light up and there is no voltage on the relay output pins.

What are those alternative connectors for?

might try and find a local relay driver module here in aus to get it at least cooling my fridge down. so hot here lately!

If your heat output is working, why not hook up the cooler to that?

Remove both actuators from your setup by setting their function to none and hit apply. Then re-add them with the functions swapped.

It sounds like the transistor on the board is not working. You could hook up an SSR to the arduino pin directly.

Hey Elco, yes that is working should have tried that earlier.

dredging up an old thread sorry.

I’m trying to add in SSR’s to my Arduino,it’s a self made shield. using the PQLYT SSRs i have everything wired correctly i think, and the - pin of the SSR running to ground on the Arduino and + pin to pin 5 on arduino (6 for the 2nd SSR)

everything is added under the maintenance tab and they are set as inverted, but when i set brewpi to off the lights on the SSR come on. When cooling occurs the led on the cooler SSR goes and vice versa for the hot SSR.

Have i wired these up wrong or am i missing some vital i.e. resistor or diode between the two pins connecting to the SSR.



If you do not have transistors in between as on the shield, you need to set them to not inverted.

excellent thank you, not having a transistor isn’t going to melt my fridge is it? i’ve tried to find the most recent Brewpi Shield but lucked out at see what transistor and where it should go.

Nope the transistors where there for compatibility with mechanical relays, with SSRs they are not needed.

1 Like