Still heating when when fridge temp has passed fridge setting


#1

Any ideas why it would continue to command heating even though the fridge temp has passed the fridge temp setting?


#2

Not with more info. I could be integrator windup or minimum on time.

The algorithm is not simple on off, the history of the error contributes via the integral part.


#3

I ended up getting it sorted out. I’ve done quite a few brews with the BrewPi and it’s worked flawlessly every time. Not sure what happened and why or if my steps actually fixed anything or were coincidental.

The beer was already cooled close to target but the freezer was already in a cold state colder than it needed to be. After a while it went into a heat mode for over 4 hours and didn’t stop until I intervened. By the time I caught it the beer was over 10F above target and the freezer was way above target. This was in beer constant.

I rebooted the BrewPi which looked like it was going to work. It stopped heating and actually started cooling. Then a couple hours later it went into heating again and overshot the target freezer temp and kept on heating.

When I tried rebooting the BrewPi again it stopped the heating and showed that it went to idle but the script said it was heating. All the refreshing and reloading didn’t change the script from reporting heating while the BrewPi reported being in idle. This persisted for a while.

Then I rebooted the BrewPi and the Raspberry Pi. Since then it behaved more reasonably and everything looks like it’s back to normal.


#4

Sounds very strange. Are you running the latest version of the firmware?

What are your pid settings?


#5

I forgot to mention, after the first couple of BrewPi reboots I went into Docker and pull the latest just in case that had something to do with it. Then later I did the BrewPi/RaspPi reboots.

My settings are default except for what we changed back when I first set it up:

Kp = 8
Maximum difference between fridge and beer set point = 12
Beer-to-Fridge derivative filter delay time =639 seconds

The only differences from any other time is the freezer was probably coming out of a colder state than the other times. It was set to freezing for a couple days before, up until not long before the fermenter was placed into it. So the walls of the freezer were probably colder than before. Even if that were to drive it to do something erratic, I dont see why it would overshoot the beer target (and fridge target) by 10F and still be trying to heat it further.


#6

Did you also update the firmware to 0.5.10? The new soon to be released platform will have many changes and much more data logging so perhaps its not worth digging deep into this issue right now.


#7

I haven’t recently. How do I check the firmware version number? Can this be done in the middle of a fermentation or should I wait until it is finished?


#8

I found in the logs I am on 0.5.1

Dec 14 2018 00:04:21 Found BrewPi v0.5.1 build 0.5.1-0-ga1d812ffa, running on a Particle p1 with a V3 shield

I guess I’ll update it when the fermentation is over in case anything strange happens.