Temp probes dropping in and out (temp, null, temp, null, etc.) -- SOLVED


#1

All,

I just wanted to share what was the A-HA moment for me.

I had an aruduino based setup running great for about 6 months – then, randomly, I started losing probes. At first, I figured I had a failing probe from being submerged in beer too long (yes, yes I know – I finally bought a thermowell), but I would continuously replace the probe and fix it, then the next day I would have all flickering null/temp/null/temp again.

After trying everything I could think of, I noticed that an employee was charging their electric bicycle on the same circuit as my brewpi. I found out that no matter which circuit the system was on, if the electric bicycle charger was also somewhere ON THE SAME CIRCUIT (not using the same plug, just the same circuit in the building), my +5V would swing from 3 to 5.5 and my probes would drop out.

I tested it with several other employee’s e-bike chargers, and I had the same result.

So – if anyone if having some sort of issue like that, check to make sure there isn’t some oscillating power draw on your circuit (or maybe this is a shielding issue? not sure).

I solved this by moving the e-bike charger to a separate circuit in the building, and everything is working great again. Hope this may help someone in the future!