Temp sensor is way off

hi, i’ve got a bit of in issue with me 2 new sensors that bought and installed. when i connected them to the arduino they read 85°c when the other sensors say 19°. when i take one sensor in my hand te see if the temp will go down they dont react at all.
anybody? some thoughts.

i’m a compleet idiot when it comes to computer code and software so please in kids talk :slight_smile:

85C is the default startup value of the sensor. The first read can return 85 when the sensor has not had the command to update its value before the value is read.

I don’t know if you are writing the software yourself, but you need to tell the sensors to start a temperature conversion, wait for it to complete (750ms), then read them.

i’m using a homemade brewpi shield and i currently have 2 working sensors and the worked perfect from the start but i wanted te replace them with the screw in type from the brewpi shop,and when i connect them they read 85° but when i update the device manager they wont change that value they keep on reading 85°

Have you tried removing all sensors from the device list (set function to none and hit apply), then without any devices installed, refresh the list?

yes and i also reprogrammed the arduino from the maintenance pannel.

they went down to 19° once but after a couple of minuts they went back up to 85

I have never heard of this happening before and the Arduino version of the software has been unchanged for about 2 years. I do think this is a hardware problem.

  • Double check your wiring
  • Measure the voltage on the 5V line of the sensors
  • Try the sensors one by one