Temp Sensors Not Detected

I had no prior knowledge of Raspberry Pi or Arduino before this project and I made it all the way to the installation of the devices and now I am stumped which is irritating I know Its probably something simple . I can not get my temp sensor (DS18B20) to show up in detectable devices. I have checked my wiring probably 10 times I have 5V going to Red, Ground going to Black and data wire going to a Digital Pin on the board with a resistor going between data and 5V. I have tried everything I can think of to get BrewPi to see my sensor. I have a meter and I know the sensor is receiving about 4.80 Volts to it are there any other test I can do?

  • Just a digital pin? or A4?
  • And is your resistor 4.7k?

I have tried both analog and digital pins and nothing has worked yet. I’m going to make sure I picked the correct resistor.

You cannot connect them to a random pin. Only pin A4 is used for OneWire with the RevC shield hex file.

Ok I did not know that. Once I switched the pin it popped right up. So I know in the future to add more sensors I just tie them all into pin A4? Thanks for the help I’m sure thats a noob mistake slowly learning this stuff.

Yes, all on the same pin. It is an addressed based protocol. The sensors listen for their address on the wire. Note the name: OneWire --> One Wire.