Test the Spark without touch screen

I seem to have this problem every time I set a new ferment off. What it basically comes down to is my touch screen doesn’t work, it never has which isn’t a problem when everything else works, but my heater seem to stop switching every now and then usually between batches, and reinstalling usually works. I can put the unit in test mode but I can’t toggle anything on/off because the touch screen doesn’t work.
Is there a way to do the same thing from the web interface? it is very frustrating watching the profile go by to see if it is going to heat.



Is it just the touch that doesnt work? or the entire screen?
Did you try re-calibrating the touch? Touch the screen at startup when it asks you.

I feel like you are describing multiple problems at once, but can’t really understand it. The heater issue seems unrelated to the touch screen.

Hi Elco,
The screen works fine from a display point of view, but does not respond to touch and never has. I have tried recalibrating the screen to no avail.
The problem I have with my heater is probably to do with the heater itself, but it is hard to diagnose without the functionality of the touch screen.

So to sum up, the heater issue could be troubleshooted if my screen worked for touch, but it doesn’t. So I have to work in ‘Live’ mode to try and see if things are working, and with the 30 min relay delay and various other things I don’t fully understand, it is frustrating.

I would like a way to simply turn my devices on and off in ‘test’ mode to check that they work. This was obviously designed to be done using the touch screen. Is there a way to do the same from the browser display.



The 30 min delay is a delay between heating and cooling. You can change it in advanced settings (dead time).

If you touch screen is broken, I can send you a new screen. Please PM me your address.

You can uninstall the heater (set function to none) and then install it again as manual actuator. Then you can toggle it from the device list.

Thanks Elco,

I wasn’t aware of the manual actuator feature it must be new, (I have just updated my system). It turns out one of my SSR’s has failed so I have ordered a couple of replacements, with heat sinks this time.

Thanks again,