Tilt data to show in Spark 4 display

Hi there, can I have my Tilt data as a tile on my Spark 4 display? For now I can only chose temp sensor data. THX Patrick

The Spark does not yet support showing SG values on the display.

With the next release, you can automatically send Tilt temperature data to Spark sensor, and display those values.

1 Like

I have a Tilt Pro that I was able to add to the dashboard without any issue. However I cannot seem to get the temperature value synced. I am following these instructions:

Sensor synchronization

Measured values can be pushed to Spark Temp Sensor (External) blocks. To set this up, create the block, and add an entry under sync to the ./tilt/devices.yml file

names: DD7F97FC141E: Purple AA7F97FC141E: Red sync: - type: TempSensorExternal tilt: Purple service: spark-one block: Purple Tilt Sensor

sync is a list of objects. Each object should have the following fields:

  • type is a constant value.
  • service is the Service ID of your Spark service.
  • block is the block ID of your Temp Sensor (External) block.

However I am not getting the expected results when the block is added to the dashboard.

We decided to release those changes now. If you run brewblox-ctl service pull tilt, the config will work as expected.

Great, I’ll give it a try…

I did and it works now. Hopefully we can have the SG implemented in the next releases…

Hi Bob, I’ve been unable to get this to work either. I’ve set up the external temp block and have it displayed on both the spark and dashboard (to confirm against the normal tilt display) and have edited the tilt devices.yml file per the instructions on the github page. I ran brewblox-ctl service pull tilt first which appeared to work fine.

Any suggestions? Would just be useful to see the tilt pro temp (and sg) on the spark in some cases.

Could you please run brewblox-ctl log ?

Figured it out, after adding the new spark service, I changed the name slightly from within the UI. However, when running the log, I saw the old name was still used so I edited the devices.yml file to point to the old name and all good now.

1 Like