Timeout setting up wifi after new firmware and fridge issue

Hi I applied the current firmware OK to my device a couple of days back, but could no longer connect over wifi. The status light was not showing a steady green colour. Other devices in the area were fine, but just in case I ran up a fresh brewblox install on a pi I can temporarily use and connected over USB. The pi is on the same 2.4G network as the spark and works fine.

The install went fine, I did a discovery and that worked plus the flash worked OK, but setting up the wifi fails. I get:

pi@brewblox:~/brewblox $ brewblox-ctl wifi
Please press ENTER when your Spark is connected over USB
INFO Pulling flasher image…
edge: Pulling from brewblox/firmware-flasher
Digest: sha256:ac8c5180d4f4cb9adbe39587b39caf1df99ed1e5b13341225ded750866c244c2
Status: Image is up to date for brewblox/firmware-flasher:edge
INFO Stopping services…
Removing network brewblox_default
WARNING: Network brewblox_default not found.
INFO Configuring wifi…
Request timeout
Command ‘docker run -it --rm --privileged -v /dev:/dev brewblox/firmware-flasher:edge wifi’ returned non-zero exit status 1.
pi@brewblox:~/brewblox $

I’ve tried holding in the reset button with a pin for 10 secs and then releasing, but I get the same thing. I’ve tried to generate a log, but I get the following, so I’m not sure how good the log is:

HTTPSConnectionPool(host=‘localhost’, port=443): Max retries exceeded with url: /spark-one/objects (Caused by NewConnectionError(’<urllib3.connection.VerifiedHTTPSConnection object at 0x75d5ee50>: Failed to establish a new connection: [Errno 111] Connection refused’))
INFO Uploading brewblox.log to termbin.com

I can then do a brewblox-ctl up and see the service running green. The frmware version is a41ceeb1 and the release date is 2020-04-09.

So that’s the first issue and any advice appreciated as it’s pretty hard to run my setup normally with USB

The second issue is to do with recreating my simple fridge setup. The 2 temp probes display expected values. I’ve done this many times before without issue, but now I get an error 500 displayed and no dashboard is created.

After this operation, I create a log without issue and it is

Any thoughts on this one appreciated too as I’m a bit dead in the water. No problem with resetting anything!

All the best

It seems we have an issue triggering setup/listening mode in the new firmware. When connected over usb, you can also enter new WiFi credentials from the top right menu on the spark service page.

If you get a 500 error, hit f12, find the failed request on the network tab and check the response. It will contain a more detailed error message.

No worries - I got the 500 error, hit F12, but not a lot showed up on the response tab (the one I think you need), so I reran setting up wifi withthe diagnostic window open and got this on the response tab.

500: CommandException(WRITE_OBJECT failed with code INSUFFICIENT_PERSISTENT_STORAGE)

That suggests that your EEPROM is full.

Before you run the wizard again, do you delete existing blocks? You can also do that from the spark page.

If you don’t, you might have created many fridge setups and hit the limit.

Great, deleting all the blocks from the UI did the trick. I had thought that doing a reset on the device would have cleared out any old junk of mine. Is there a better way than just holding in a pin in the reset hole to really do a full reset?

I have a fair number of different setups with only a few temp sensors to hand, so I have got into a habit of running the wizard to set up what I need at that time, so yes I bet there is a fair amount of old unused stuff lying around!

You can remove all blocks on the service using the actions menu in the Spark service page. This will reset everything on your Spark except the firmware and its Wifi.

See https://brewblox.netlify.com/user/removing_things.html for more details. We’re also working on a way to more clearly communicate this, as it’s a very common oversight.

Thanks Bob. I’m back on my wifi connection on my regular server and managed to create my standard fridge rig without any problems. The very prompt response from the team is very much appreciated