Trending not working

Haven’t brewed any beer in a while, can’t have anyone over to drink due to corona virus… But I noticed my trending has stopped. Says it is active but always show no data.

Not a big deal but not sure what is going on…

Can you run brewblox-ctl log?
Also run df -h to check free space.

The log file looks like it went to ???

You have 250GB on your pi? Wow.
Yes, the log file will upload to termbin and give you a link to share.

I did this to the pi…

Added SSD.

I like the form factor, but isn’t the Pi data bus a major bottlenneck?

Was there anything in the log file ?? Should I try shutting the server down and restarting ??

We don’t know - we need a link to check. When you run brewblox-ctl log, you indeed get a termbin url, but you have to post the full url in order for us to look at it.

Sorry, somehow I missed that part…

You may want to update or reinstall, depending on how many changes you made to the default configuration. It looks like your service and got controller got slightly out of sync, but we fixed multiple bugs the past five months that may be responsible.

I think you’ll be pleasantly surprised.

Completely missed that he had not updated in 5 months!
Yeah, try that first :slight_smile:

After updating the services, you probably have to update the Spark over USB because it is so out of date, with the command ‘brewblox-ctl flash’.

The services update went fine. When I tried to update the Spark I got this…

That’s a connection issue. Run ‘brewblox-ctl down’ and try again.

I also recommend running brewblox-ctl disable-ipv6. Reboot afterwards with the reboot command.

Got it !! restarted everything and it seemed the server didn’t have a wireless connection. Did a restart on it and the wireless came up and the flash of the Spark worked. It is collecting data now !! Have to recenter a little in the brewery builder but it’s all updated and up and running. As always thanks for your help and patience !!