Unable to get spark v2 connected

Hello Elco, a few weeks ago, I finally found some time to install brewblox.
Up to now I tried all kind of different things, but i run out of ideas…
I have a rpi2b, powered with a 5.1V , installed software on 2 different SD cards, brewblox is up to date, UI is running fine.
Spark V2 is connected to rpi via USB, separate power supply 12V, blank, white screen, 1 temp sensor and 1 SSR attached for purpose of testing.
Spark had all functionalities working fine with former brew software.

brewblox-errors-2.json (246 Bytes)


Did you configure Wifi on the Spark? The bootloader is updated automatically over Wifi. White screens normally happen when the bootloader is not yet updated.

Hi, no I didn’t configure the wifi on Spark, I flashed it via USB until now.
However, this morning ,I removed the Spark housing, and I just found out that the inner plug of the micro-USB connector is broken.
The plan was to buy a Brewpi Spark 3 for a Herms setup , and to fix the Spark2 for a future fermentation setup.
Since Spark3 seems not to be available now, I just ordered already a Particle Photon for the Spark2, I hope the older ‘Brewpi USB port broken’ thread in the forum will put me on the right track whenever my Spark 2 is back in business.
Thank you for the fast reply,

Sad to hear about the USB connector =(

By the looks of it is the information in that thread still current. Do feel free to ask if anything is unclear.

The new Particle Photon has arrived and is installed, I did run through a complete new setup, wifi is now configured on the Spark.
However, the initial main problem remains :
Spark service is running, but not connected to controller, see screen shot below

  Just for info : Spark is connected with Rpi over USB  (displayed in shadowed grey , on top left in 
  Spark display) (i have a RPI 2, no dongle, UTP cable connection to home- network) 
  Spark is showing WIFI and its IP address in bright white, right next to the greyed USB indication

  Does this mean that Spark communicates with Rpi over Wifi (and homenetwork) rather then using 
  the USB cable in between them ? 

When I try the Quick Start Wizardry, I get the following error :

I also run through Brockayers posts, and did a brewblox-ctl setup to produce new datastore files, but this didn’t solve anything.

brewblox-errors.json (1.6 KB)


Did I miss anything ?

It means the Spark is connected over Wifi to your home network. It depends on your router config whether your cable-connected devices (your Pi) can see Wifi-connected devices (your Spark).

If you have installed the latest update (2019/12/03), you can run brewblox-ctl discover to check whether the Spark can be found.

If it can’t be discovered, you could possibly still directly connect to the Spark. To check whether it’s network-accessible, run curl http://IP_ADDRESS. (replace IP_ADDRESS).

The response should be something like:

<html><body><p>Your BrewBlox Spark is online but it does not run its own web server. Please install a BrewBlox server to connect to it using the BrewBlox protocol.</p><p>Device ID = 280038000847343337373738</p></body></html>

If your Spark can’t be discovered, but is network-accessible: run brewblox-ctl add-spark --force --name spark-one --device-host IP_ADDRESS (replace IP_ADDRESS with the IP on your Spark).


Yes !!! It is up and running now, thanks.
Spark couldn’t be discovered, but was accessible through the network, so the
brewblox-ctl add-spark --force --name spark-one --device-host IP_ADDRESS did the job.

I will study the user guide-spark connection settings page to get some background,
once again, thank you for your helpful answer,

Happy to hear it worked!

When directly using --device-host, it’s advisable to set a static DHCP lease for your Spark in your router, to prevent it having a different IP in a week or so.