Unable to "install" temp sensors via maintenance panel

Hey guys! Just started to run into this issue yesterday for no apparent reason. When i choose either Chamber or Beer device, select the function, hit apply i see the “Device config command sent” but when i refresh they are still no installed.

Any clues? They were working the other day, the only thing i have done is swap the probes around on the shield but that is nothing i haven’t done before.

I’m running a RevA shield with the latest software.

Never mind! figured it out all i needed was a good nights sleep and to post this question here oh man.

1 Like

I’ve experience that before a reboot of the pi seemed to fix it

Just to shed some light on a possible cause of this:

  • Invalid configs are ignored
  • After reprogramming the Arduino, an EEPROM reset has to be performed before any data can be overwritten. Before this is done, the script backs up the settings. This is to prevent corrupt EEPROM and data being lost. Nothing is written to EEPROM until that reset. The programming script takes care of this.

It was a little more simple than that, in my sleepiness i failed to assign a port! hah!

Anyway, all good just now one of the probes is returning null value. onwards.

Try removing all devices (set function to none and apply).
With none of them installed, try reading values.
Then re-add them one by one.
If you still have the same issue, check your hardware.
If a sensor is discovered, but cannot read a value, check the 5V connection.

Please also see: Troubleshooting temperature sensors

cool yeah that worked. i think my wiring is a tad dodge. just temporary anyway while i’m rebuilding it