Unable to read out temp sensors


I have brewblox up and running, but now I am stuck, and really need some help.
To learn the system, I tried a few single sensor control chains, all went fairly well, until I configured the Herms setup via the wizard.Then, I deleted the BK part, and tried the HLT and MT setup.
The system is producing some kind of output on the digital actuator, (SSR and heater function) but both the HLT and MT sensors seem to be stuck in kind of ‘a coma’,
no readout on Spark V2 display, just dashes…
I tried other settings in dialog boxes, unplugged sensors, restarted Spark, went through troubleshooting posts, etc, no result.
In the end, I opted for a fresh install after formatting SD card, according to the ‘getting started’ steps.
I would have thought to have a blank system, but to my surprise, the Spark controller seemed to have ‘found’ the old service, and the display was still showing the ‘deleted’ display settings.
I then run through the wizard to setup the Herms again, deleted blocks that I didn’t need, and also deleted the retained blocks of the former setup. I am back to square one, and still stuck.
I am quite sure the software got installed well, but it seems like I have somehow messed up the service on the rpi.
So I better wait until you publish an in depth user guide, since the functionality of the system is not completely clear yet for me.
I did include the system logs if you would want to have a look into it.

Thank you in advance.

brewblox-blocks-spark-one.json (4.0 KB) brewblox-logs.json (228 Bytes)

The Spark is independent, and is the one storing Blocks.
You can see blocks on the service page in the UI.
Dashboards / widgets use references to blocks. You can remove them without removing the blocks themselves.

You can reset blocks on the spark page (actions button top right). You can also use the spark page to edit which blocks are displayed on the spark lcd.

After the latest update, we updated and added some user guides. This includes pages about the behavior that had you confused.

I was struggling with the configuration , your explanation put me in the right direction. Thank you for the expanded info in the new chapters of your User Guide, very helpful !

It turned out that the second onewire temp probe had a bad contact in its plug. All is functioning again now.
I will order a spare to have a backup.

Thank you once again,