Unsecure Website Error

I have the same error.


brewblox-ctl log also shows an URL, could you copy-paste that here please?

@r_vandenbroek Thanks for letting us know =) It seems to have popped up recently, and we’re looking into it.

1 Like

I don’t seem to see a brewblox-ctl.log file if that’s what you are referring to? I did realize that my screen dump was not complete. Here is the entire brewblox.log file.


brewblox.log (121.8 KB)

The command is brewblox-ctl log. When you run it, it automatically uploads your log to termbin.com. You get an URL for that, which you can share.

Uploading the file is also fine =)

I think you’re having problems with a bug we fixed in a recent update. Can you run this command, and check whether it then works?

brewblox-ctl update

@r_vandenbroek the makecert error turned out to have a simple workaround on our side, so we decided to push that change live now.

To get it, either run brewblox-ctl update, or (if you’re already using the latest version) brewblox-ctl libs.

1 Like

Unfortunately an error: https://termbin.com/gpt0

Does it work if you run brewblox-ctl down first? What is the makecert error? Logs don’t show terminal output.

brewblox-ctl down didn’t help.

This is the error:

pi@raspberrypi:~/brewblox $ brewblox-ctl makecert
Command is about to: Generate a self-signed SSL certificate.
Do you want to continue? (yes, no, verbose, dry-run) [press ENTER for default value 'yes']y
unknown flag: --pull
See 'docker run --help'.
Command 'docker run --rm --privileged --pull always -v "/home/pi/brewblox/traefik":/certs/ brewblox/omgwtfssl:edge' returned non-zero exit status 125.

Looks like the --pull arg was introduced in january.

You can fix that by updating system libraries: sudo apt update && sudo apt upgrade -y. I’ll probably do a tweak on our end as well to improve compatibility.


Been out of town for an extended period of time. Just now getting back to this. I ran brewblox-ctl update.

At the very beginning of the execution, it posted this error: docker-compose 1.29.0 has requirement docker[ssh]>=5, but you’ll have docker 4.4.4 which is incompatible

And at the very end, it posted the same statement and while it said the update was successful, it wont return me to the command prompt. All I have is a “>”

The > is shown if you accidentally also pressed the \ button while pressing Enter.
Press Enter again to get rid of it.

To fix the docker version error, you can run:

pip3 install --user --no-cache-dir -I -U docker

It seems to be happening more often, so I’ll have a look at making our updater more specific about the desired version.

So I did hit enter again and the putty interface gave me a “Software error caused a disconnect” and dumped me out.

Restarted putty and started a new session and I’m just getting a time-out connection error. Looks like the Pi is unresponsive.

The fastest way to fix that is to unplug and reconnect your Pi, and then reconnect when it’s done starting up.

Apart from freak problems, the only issue I’m aware of that caused Pi hangups was IPv6-related. You can run brewblox-ctl enable-ipv6 to be sure the fix is applied.

Okay, it looks like I’ve updated docker to 5.0.0
and I ran the ipv6 enable command just to be sure.

and when this last command completed, I again got the same putty connection error - s/w caused connection abort - and I lost the session.
brewblox unresponsive after ipv6 command

Putty Fatal Error

I’ll shut power off on the Pi again and restart.

Okay, back up. and I’ve now gone back to a web browser after doing all these updates and I still have the Unsecure Website Error. So I think I still need to rebuild the certificate - right? Haven’t done that since the first attempt. So that’s what I’m doing next…

okay, so i ran the three commands to rebuild the cert as you noted above (down, makecert, up). I also rebooted the Pi.

Went to the web browser and unfortunately, I still have the Unsecure website error :frowning:

I ran brewblox-ctl log
But there is an error from termbin.com:

“getaddreinfo for host “termbin.com” port 9999: temporary failure in name resolution
Command ‘cat brewblox.log | nc termbin.com 9999’ returned non-zero exit status 1.”

What happens if you run ping termbin.com? It may just be a temporary hiccup.
If the ping works, you can retry the command:

cat brewblox.log | nc termbin.com 9999

To otherwise start with the simple questions: have you hard refreshed the UI page (ctrl-F5)? Is this still the unsecure website error without an “advanced” button that lets you continue anyway?

ping: termbin.com: Temporary failure in name resolution

Then I guess there’s a DNS server between you and them having a bad day. Not the end of the world.
What about the other questions?

Weird (again) I just tried the Cat command for Termbin and it worked. Here is the log

Also, I did try Crtl F5

In Chorme, it will not let me proceed.
In Firefox, it will but posts the error icon on the address line.
In Edge, it will not let me proceed.
In Explorer, it just spins…