Update failing - no matching manifest

I’ve recently started up my BrewPi after almost a year and a half and am having trouble getting back into action. I’ve updated/upgraded the BrewPi as much as possible. When I run “brewblox-ctl update” it generates a few errors like this:

ERROR: for history manifest for brewblox/brewblox-history:rpi-edge not found: manifest unknown: manifest unknown

ERROR: for influx no matching manifest for linux/arm/v7 in the manifest list entries

ERROR: for ui manifest for brewblox/brewblox-ui:rpi-edge not found: manifest unknown: manifest unknown
ERROR: no matching manifest for linux/arm/v7 in the manifest list entries
Command ‘docker-compose pull’ returned non-zero exit status 1.

It also seems, right now, that my BrewPi cannot connect to the Spark. When I run brewblox-ctl discover, it can find it both via usb and wifi.

Also, my brewblox-ctl doesn’t seem to have a handful of commands that I see referenced on the internet. For example “brewblox-ctl backup save.” This makes me wonder if I’m still on an older version of some software.

The pastebin link for the logs is: https://termbin.com/2gch

Thanks in advance!!

If you’re using a relatively default fridge fermentation setup, I recommend a clean reinstall. This is likely to be much faster than to tweak the various older configuration options.

To do so:

cd ~
mv brewblox brewblox-bak
pip3 install --upgrade brewblox-ctl
brewblox-ctl install
cd brewblox
brewblox-ctl setup
brewblox-ctl flash

This moves your current configuration to a backup dir before reinstalling the system.
If you want to preserve custom configuration or history data, we can then import the old data to the new system.

Thanks Bob, it’s a fairly simple HERMS setup, so I’m happy to reinstall. I followed the commands until the pip3 install. This seemed to complete correctly, however, it did not create a new folder called brewblox. Did I miss a step?

Thanks much,

The pip3 install ensures you have the latest version of brewblox-ctl inself, and then brewblox-ctl creates the brewblox dir, and brewblox-ctl setup creates most of the settings files inside it.

Thank you Bob, I think I’m on the right track. I’ve been able to run through the wizard and update the diagram to look like my setup. As of now, I have two issues. The first is that I have on extra service (I tried to add another spark before I opened this issue. Obviously it didn’t help.) When I run brewblox-ctl service show it only shows me the active service. But in the UI I still see the extra one. When I click Remove from UI, nothing happens.

Second, the graph in the dashboard is not tracking anything. The system has been running for over 12 hours now with no data. I can see the temperatures of the sensors in the kettles and I’ve selected every check box in the graph settings. It still says no data for selected period. The selected period is “Live: duration to now” Duration: 10m

Thanks again!

If you run docker-compose restart eventbus, reload the UI, and remove the service in the UI, it should not reappear.

There are multiple possible explanations for the graph issue. Could you please run brewblox-ctl log to provide some more info?

I tried the steps above and the extra service is still not being deleted. Something is still off. I tried to run brewblox-ctl update and it said “This configuration was never set up…” Even though I thought I had already run this, I did it anyway. I received the error "cp: cannot create regular file ‘./traefik/traefik-cert.yaml’: Permission denied. I then reran the update command with the same error.

I ran the log command and the link is: https://termbin.com/9qmq

Thank you!

The UI service is currently not responding to deletion, because the backend isn’t running. You can ignore that for now, and remove the UI service after the backend is up again.

The log indeed reports that setup hasn’t been completed yet (maybe it errored out?).
To fix, run:

sudo rm -rf ./traefik
brewblox-ctl setup

This should complete without errors, and afterwards the UI should be responsive again.
The Spark firmware is likely to be outdated as well. If setup completed ok, you can update this by running

brewblox-ctl flash

Thank you Bob, this seems to have helped! The initial setup has completed successfully and the spark has flashed successfully. I still cannot delete that extra service. I have rebooted everything and run “docker-compose restart eventbus” again.

Does the problem persist if you force reload the UI?

What is the output of

brewblox-ctl http post http://localhost/history/datastore/mget -d '{"namespace": "brewblox-ui-store:services"}'

I might not know exactly how to force reload the UI.

The output of the above command is:
{“values”: [{“namespace”: “brewblox-ui-store:services”, “id”: “spark-one”, “type”: “Spark”, “title”: “spark-one”, “order”: 2, “config”: {}}, {“id”: “spark”, “namespace”: “brewblox-ui-store:services”, “config”: {}, “order”: 1, “title”: “delete”, “type”: “Spark”}]}

The service I’m trying to delete is called “delete.”

Thanks again!

I’ll have a look at what’s going on in the UI. In the mean time, you can remove the service by running

brewblox-ctl http post http://localhost/history/datastore/delete -d '{"namespace":"brewblox-ui-store:services", "id": "spark"}'

You can force refresh the UI with ctrl-F5

Worked like a charm, Bob. Thank you for all your help!

I owe you a beer!