Update problem pip error?


I tried brewblox-ctl update. Here is part of the screen.

. .venv/bin/activate
python3 -m pip install --upgrade pip
python3 -m pip install --prefer-binary ./brewblox-ctl.tar.gz

Then re-run brewblox-ctl update.


Still some problems?

Did you run all three commands?


All 3 commands, success except for tilt. I don’t use tilt anymore so I assume there is no problem.
I see no indication for updating the Spark. If so, please help me

as I don’t remember the command.
Thank you very much for your help here!

The update is not yet done if the (old) tilt service caused an error.
Run brewblox-ctl service remove tilt to remove the service, and then re-run brewblox-ctl update.

To update the Spark firmware, use brewblox-ctl flash

I have now run update, flash and up with no error messages. The system is not working. Can you see anything in the log file?


Everything looks normal. How is the system not working?

Seems to be working now, there was an enable that had somehow switched. It’s been a while since I worked with BrewBlox.
Good to know that the log-file shows no errors, sorry to bother you with trifles.
I am very happy for your help!

1 Like

I have had a brewday. For graphs I can select values but they do not show. When I select the same values on a metric they display.

I can give some more information, hopefully to assist our common troubleshooting. My problems arose after the last update. The previous update was around July 7. 2022. I see some of the same graph problems on all dashboards, but will describe what I see on the fermentation one.
For a graph I select “ferment cool pwm- value”. The screen shows no data (yet). The metric shows the value. When I also select “ferment cool - setting”, both graphs turn up. When I again turn of “setting”, the “value” graph is still there and working fine.
Also, under quick actions, when I press a button, it becomes green on the Fermentation dashboard as it always has. However, on my HERMS and Boil dashboards the green on the button does not appear as it has done before the last update. The label on the bottom of the screen turns up nicely on all dashboards.
I hope this is helpful.

We’re aware of issues with fetching graph data, and are looking into the problem. The symptom of it appearing when you select another field is new.

Could you please export the quick actions widgets on your HERMS and Boil dashboards? We changed some field names in the last update, and it’s possible not all widgets were updated automatically.

Here are the quick action wizards.
brewblox-Boil Actions-QuickActions.json (3.0 KB)
brewblox-HERMS Actions-QuickActions.json (11.6 KB)
Also the Fermentation wizard.
brewblox-Ferment Actions-QuickActions.json (5.0 KB)

It looks like the setting migration didn’t apply here. Some of your actions are still using the settingEnabled field instead of enabled. We’ll automatically fix this in the next release, but you can also do this manually to get it fixed now.

If you edit the Quick Actions, it will show a warning about the unknown field “settingEnabled”. Click the prompt to remove this field, and add the “Enabled” field to affected block changes.

I’ve listed the desired settings below:

  • Boil actions
    • Constant temperature
      • Boil Setpoint = true
    • Constant PWM
      • Boil Setpoint = false
    • Disable control - reset PID
      • Boil Setpoint = false
  • HERMS actions
    • Constant mash temperature - 1 PID
      • HERMS HLT Setpoint = true
      • HERMS MT Setpoint = false
    • Mash profile temperature - 1 PID
      • HERMS HLT Setpoint = true
      • HERMS MT Setpoint = false
    • Constant HLT temperature - 2 PID
      • HERMS MT Setpoint = false
    • Constant mash temperature - 2 PID
      • HERMS MT Setpoint = true
    • HLT profile temperature - 2 PID
      • HERMS HLT Setpoint = true
      • HERMS MT Setpoint = false
    • Mash profile temperature - 2 PID
      • HERMS HLT Setpoint = true
    • Disable control - reset PID
      • HERMS MT Setpoint = false
      • HERMS HLT Setpoint = false
  • Ferment actions
    • Constant fridge temperature
      • Ferment Fridge Setting = true
      • Ferment Beer Setting = false
    • Constant beer temperature
      • Ferment Fridge Setting = true
      • Ferment Beer Setting = true
    • Disable control - reset PID
      • Ferment Fridge Setting = false
      • Ferment Beer Setting = false

Hi again,
The system is working and doing its job. However, the quick action buttons don’t always turn green. My question today is what makes the buttons go green what does that tell me?

The button is green when actual block settings match the settings that will be applied by the quick action.

If the button doesn’t turn green, it may be due to a field name that wasn’t migrated properly. We renamed the setpoint settingEnabled field to enabled, but we’ve had some reports that the automatic migration in Quick Actions sometimes failed to apply.

If you open Quick Actions settings, it will let you know if there are any unrecognized fields. Next release includes a fix to this issue, and is expected to go live later today.