Update question

I get this message on update. What gives?

After update the Spark screen is black and the blue light is quicker then the normal breathing.

Here is some more info

The first error can be solved by running

pip3 install --user --no-cache-dir -I -U docker

I suspect the second error is caused by the first, but please let us know if it doesn’t go away.

I have done update, flash, flash-bootloader and update. Seem to be OK now.

Do you still recommend pip3 install --user --no-cache-dir -I -U docker?

Did update still complain about the version? If not, it already applied that fix by itself.

I am having some problems today. Yesterday I set BrewBlox up with the tilt hydrometer and it worked. Today, the BrewBlox did not receive data from the tilt. The tilt worked well on the tilt-2 app on my phone.

I tried update, but the Pi fell out. It seems to be very slow when I run it directly.

I ran (twice) pip3 install --user --no-cache-dir -I -U docker and got this result.! Capture_Update_3|690x232

Your docker version is fine now. I’ll have a look at why pip thinks brewblox-ctl requires <5.

To check: are you using a 5.1V charger for the Pi?. Underpowered chargers can cause slowdowns and crashes.

Could you please run brewblox-ctl log? The Tilt depends on bluetooth, which can be finicky.

Log is joe7

I am using USB direct and a 12V supply.

This is the Spark, but the Pi seems fine as well (no underpowered warnings in log). If you’re not using an official charger, it’s probably still good to check.

Your Tilt service detected a red Tilt at 9:42 UTC, and hasn’t logged anything since.

You could restart the tilt service to reset its connection to the bluetooth adapter

docker-compose restart tilt

Connection of your Pi and your phone also matter. Does your app still have a good signal when held roughly next to your Pi?

I measured the voltage during load 5.1V. Swings +/- 0.5 V.

The R Pi does not come up every start. It can also fall out in the middle of an update. There is someting unstable here.

App and BrewBlox coincide on signal strength.

What are you using to power the raspberry pi?
A phone charger is not sufficient. It will drop under heavy load, which can be short bursts.
These bursts will be too short to measure with a multimeter, it would require an oscilloscope.

If you want a reliable system and want to avoid data loss, you should power the raspberry pi with a power supply designed for the job. The official ones are good.

It could be you are right here. The voltage seemed to be stepping around +/- 0.5V as if there was a transient load. Perhaps I should get the 3A supply they use on the R Pi 4.

Specs seem okay, and it seems to be designed for the pi (brand is GEEEKPI).
It might be good, but I don’t know. If you measure fluctuations, trying another power supply is a quick and cheap solution to try.